summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2019-03-30 14:32:12 +1100
committerWesley Moore2019-03-30 14:32:12 +1100
commit61e7de66d05753db9d83edca60ff7be151ad7e43 (patch)
tree7fd1fc1755d5597f597f9ab5d37308d07e857b39
downloadaur-61e7de66d05753db9d83edca60ff7be151ad7e43.tar.gz
Initial commit; Buckets 0.53.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6961fe54d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = buckets-bin
+ pkgdesc = Private budgeting with the envelope budgeting method
+ pkgver = 0.53.1
+ pkgrel = 1
+ url = https://www.budgetwithbuckets.com/
+ arch = x86_64
+ license = custom: commercial
+ depends = alsa-lib
+ depends = gtk3
+ depends = libsecret
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = glibc>=2.28-4
+ noextract = Buckets_0.53.1_amd64.deb
+ source = https://github.com/buckets/application/releases/download/v0.53.1/Buckets_0.53.1_amd64.deb
+ sha256sums = 1ba541dd3817e1dd8121f28ea9cc1d17d2bfc5a96b41a8aec65c21c46f0cab1c
+
+pkgname = buckets-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1edc08cb53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Wesley Moore <wes@wezm.net>
+
+pkgname=buckets-bin
+_pkgname=Buckets
+pkgver=0.53.1
+pkgrel=1
+pkgdesc="Private budgeting with the envelope budgeting method"
+arch=('x86_64')
+url="https://www.budgetwithbuckets.com/"
+license=('custom: commercial')
+depends=('alsa-lib' 'gtk3' 'libsecret' 'libxss' 'libxtst' 'nss' 'glibc>=2.28-4')
+optdepends=()
+source=("https://github.com/buckets/application/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
+noextract=("${_pkgname}_${pkgver}_amd64.deb")
+sha256sums=('1ba541dd3817e1dd8121f28ea9cc1d17d2bfc5a96b41a8aec65c21c46f0cab1c')
+
+package() {
+ bsdtar -O -xf "${_pkgname}_${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ install -d "${pkgdir}/usr/bin"
+
+ # Remove unnecessary stuff
+ rm -rf "${pkgdir}/usr/share/doc"
+
+ ln -s /opt/${_pkgname}/buckets "${pkgdir}"/usr/bin/buckets
+}
+