summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2022-08-28 14:18:15 +0100
committerKuoi2022-08-28 14:18:15 +0100
commit7b16c601e31adc8a30ca8c1fbbbb288347e64ea0 (patch)
tree5634994f87ae912c9024a5c6dec17be1befb444b
parentaa3db4a221598bc6db4c05a47f1922be8ded9dc7 (diff)
downloadaur-7b16c601e31adc8a30ca8c1fbbbb288347e64ea0.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 29 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4993e9ed8191..061996b77655 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = bucky
- pkgdesc = bayesian concordance analysis
+ pkgdesc = Bayesian Untangling of Concordance Knots https://doi.org/10.1093/bioinformatics/btq539
pkgver = 1.4.4
pkgrel = 1
- url = http://www.stat.wisc.edu/~ane/bucky/index.html
- arch = i686
+ url = https://github.com/tkchafin/mpi-bucky
arch = x86_64
- license = GPL2
+ license = GPL
+ makedepends = clang
makedepends = boost
depends = gcc-libs
- source = http://www.stat.wisc.edu/~ane/bucky/v1.4/bucky-1.4.4.tgz
- md5sums = f0c910dd1d411d112637826519943a6d
+ depends = boost-libs
+ conflicts = mpi-bucky
+ source = http://dstats.net/download/http://www.stat.wisc.edu/~ane/bucky/v1.4/bucky-1.4.4.tgz
+ sha256sums = 1621fee0d42314d9aa45d0082b358d4531e7d1d1a0089c807c1b21fbdc4e4592
pkgname = bucky
-
diff --git a/PKGBUILD b/PKGBUILD
index e746409617dd..c10f85367654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
-# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
-
pkgname=bucky
pkgver=1.4.4
pkgrel=1
-pkgdesc='bayesian concordance analysis'
-arch=('i686' 'x86_64')
-url="http://www.stat.wisc.edu/~ane/bucky/index.html"
-license=('GPL2')
-depends=('gcc-libs')
-makedepends=('boost')
-source=("http://www.stat.wisc.edu/~ane/bucky/v1.4/$pkgname-$pkgver.tgz")
-md5sums=('f0c910dd1d411d112637826519943a6d')
-
-prepare() {
- cd $srcdir/$pkgname-$pkgver/src
-
- rm -rf boost
-}
+pkgdesc="Bayesian Untangling of Concordance Knots https://doi.org/10.1093/bioinformatics/btq539"
+arch=('x86_64')
+conflicts=('mpi-bucky')
+url="https://github.com/tkchafin/mpi-bucky"
+license=('GPL')
+depends=('gcc-libs' 'boost-libs')
+makedepends=('clang' 'boost')
+source=("http://dstats.net/download/http://www.stat.wisc.edu/~ane/bucky/v${pkgver%.*}/bucky-${pkgver}.tgz")
+sha256sums=('1621fee0d42314d9aa45d0082b358d4531e7d1d1a0089c807c1b21fbdc4e4592')
build() {
- cd $srcdir/$pkgname-$pkgver/src
-
- make
+ cd "$srcdir/$pkgname-$pkgver/src"
+ for file in TaxonSet Alias mbsumtree TGM Quartets mbsumtree
+do
+ clang++ -c $file.C
+done
+clang++ bucky.C TaxonSet.o Alias.o mbsumtree.o TGM.o Quartets.o -o bucky
+clang++ mbsum.C mbsumtree.o -o mbsum
}
package() {
- cd $srcdir/$pkgname-$pkgver/src
-
- install -Dm755 bucky $pkgdir/usr/bin/bucky
- install -Dm755 mbsum $pkgdir/usr/bin/mbsum
+ cd "$srcdir/$pkgname-$pkgver/src"
+for bin in bucky mbsum
+do
+ install -Dm 755 $bin $pkgdir/usr/bin/$bin
+done
}