summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-06 10:09:25 +0800
committerzxp198210052024-02-06 10:09:25 +0800
commit3fff6ed3f1bffd98264b679602ed9b36cb608acb (patch)
tree363508f1f73829786d96ecdf34bf6a0a3f82aba4
parent60b75e54fd4d63c0b62d481bfaaa34bde09247d8 (diff)
downloadaur-3fff6ed3f1bffd98264b679602ed9b36cb608acb.tar.gz
update to 1.2.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--budgeted-ui.sh6
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a793ae8c31e3..af23d4442587 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = budgeted-ui-bin
pkgdesc = A data pipeline for budget data and so much more
- pkgver = 1.1.1
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/politicker/budgeted
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = budgeted-ui-bin
depends = openssl-1.1
depends = nodejs
depends = hicolor-icon-theme
- provides = budgeted-ui=1.1.1
+ provides = budgeted-ui=1.2.1
conflicts = budgeted-ui
- source = budgeted-ui-1.1.1.deb::https://github.com/politicker/budgeted/releases/download/v1.1.1/budgeted-ui_1.1.1_amd64.deb
+ source = budgeted-ui-1.2.1.deb::https://github.com/politicker/budgeted/releases/download/v1.2.1/budgeted-ui_1.2.1_amd64.deb
source = budgeted-ui.sh
- sha256sums = 7bc93e6c66f988017b0b4dcefd5b2e1bfb094f0b1e93b6f502cffc8bbce53e70
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 72c43d9d5021c7bd660372c0917a05bf56bacd19dbe0a5c3fcde8d426a2ac585
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = budgeted-ui-bin
diff --git a/PKGBUILD b/PKGBUILD
index b9b52af1862a..ae5c2aaf4796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
_pkgname=budgeted
pkgname="${_pkgname}-ui-bin"
-pkgver=1.1.1
+pkgver=1.2.1
_electronversion=28
pkgrel=1
pkgdesc="A data pipeline for budget data and so much more"
@@ -20,12 +20,12 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('7bc93e6c66f988017b0b4dcefd5b2e1bfb094f0b1e93b6f502cffc8bbce53e70'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+sha256sums=('72c43d9d5021c7bd660372c0917a05bf56bacd19dbe0a5c3fcde8d426a2ac585'
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/budgeted-ui.sh b/budgeted-ui.sh
index 0d20cddc70ca..f9ced1432cfc 100644
--- a/budgeted-ui.sh
+++ b/budgeted-ui.sh
@@ -1,14 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file