summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Dubosson2015-05-29 13:15:13 +0200
committerFabien Dubosson2015-05-29 13:15:13 +0200
commit23f21ca59282b111e87be5a28b866ecbef84ceab (patch)
tree8a6ed8aeec3bba1730a6500647b6f144740ffc3d
downloadaur-23f21ca59282b111e87be5a28b866ecbef84ceab.tar.gz
Move 'budgetwarrior' into separate repo for AUR4
-rw-r--r--.SRCINFO17
-rw-r--r--ChangeLog31
-rw-r--r--PKGBUILD36
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee2d4177310f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = budgetwarrior
+ pkgdesc = Simple command line utility to helps keeping track of your expenses and the state of your budget.
+ pkgver = 0.4.1.2
+ pkgrel = 1
+ url = https://github.com/wichtounet/budgetwarrior
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = clang
+ depends = boost
+ depends = util-linux
+ source = https://github.com/wichtounet/budgetwarrior/archive/0.4.1.2.tar.gz
+ md5sums = b0120b7265b71a34035f1cb622feeff8
+
+pkgname = budgetwarrior
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..600f132f2fdc
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,31 @@
+2014-09-24 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.4.1.2-1:
+ New upstream release
+
+2014-09-21 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.4.1-1:
+ New upstream release
+
+2014-07-06 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.4-1 :
+ New upstream release
+
+2014-05-11 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.3.1-1 :
+ New upstream release
+
+2014-02-04 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.3.0-1 :
+ New upstream release
+ Uniformalize PKGBUILD notations
+
+2014-01-28 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.2.2-1 :
+ Package created
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c609b3f24c33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Fabien Dubosson <fabien.dubosson@gmail.com>
+
+pkgname="budgetwarrior"
+pkgver="0.4.1.2"
+pkgrel="1"
+pkgdesc="Simple command line utility to helps keeping track of your expenses and the state of your budget."
+url="https://github.com/wichtounet/budgetwarrior"
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('clang')
+depends=('boost' 'util-linux')
+changelog="ChangeLog"
+source=("https://github.com/wichtounet/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('b0120b7265b71a34035f1cb622feeff8')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/man/man3"
+ install -d "${pkgdir}/usr/share/zsh/site-functions/"
+ install -d "${pkgdir}/etc/bash_completion.d"
+ make prefix="${pkgdir}/usr" install
+}
+
+# vim:set ts=4 sw=4 et: