summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCampbell Jones2022-07-17 18:27:59 +0100
committerCampbell Jones2022-07-17 18:27:59 +0100
commit3ce881d317dcec8ffdc3e831a8d6d57fc40f0ff6 (patch)
tree5b736468c7378e578521efe38e5e4fc509e606be
parent1a3d38286f0410b2dc7a11ed5c88b428ce74d587 (diff)
downloadaur-3ce881d317dcec8ffdc3e831a8d6d57fc40f0ff6.tar.gz
Update to v1.2 and update metadata
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD39
2 files changed, 18 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00caf7605de0..5e666e90c4ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = budgie-desktop-view-git
- pkgdesc = The official Budgie desktop icons application / implementation -- latest git
- pkgver = v1.0.2.r0.g39641f2
+ pkgdesc = The official Budgie desktop icons implementation - latest git
+ pkgver = 1.2.r0.g1f30d69
pkgrel = 1
- url = https://solus-project.com/budgie
+ url = https://github.com/BuddiesOfBudgie/budgie-desktop-view
arch = x86_64
- license = APACHE
+ license = Apache-2.0
makedepends = meson
makedepends = git
makedepends = gobject-introspection
@@ -14,8 +14,7 @@ pkgbase = budgie-desktop-view-git
depends = budgie-desktop
provides = budgie-desktop-view
conflicts = budgie-desktop-view
- source = git+https://github.com/getsolus/budgie-desktop-view.git
+ source = budgie-desktop-view-git::git+https://github.com/BuddiesOfBudgie/budgie-desktop-view.git
md5sums = SKIP
pkgname = budgie-desktop-view-git
-
diff --git a/PKGBUILD b/PKGBUILD
index de4d48cd445e..c68c7515ef74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,32 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
+# Maintainer: Campbell Jones <dev at serebit dot com>
pkgname=budgie-desktop-view-git
-pkgver=v1.0.2.r0.g39641f2
+pkgver=1.2.r0.g1f30d69
pkgrel=1
-pkgdesc="The official Budgie desktop icons application / implementation -- latest git"
+pkgdesc="The official Budgie desktop icons implementation - latest git"
arch=('x86_64')
-url="https://solus-project.com/budgie"
-license=('APACHE')
-depends=(
-budgie-desktop
-)
-makedepends=(
-meson
-git
-gobject-introspection
-intltool
-vala
-gtk-doc
-)
+url="https://github.com/BuddiesOfBudgie/budgie-desktop-view"
+license=('Apache-2.0')
+depends=(budgie-desktop)
+makedepends=(meson git gobject-introspection intltool vala gtk-doc)
provides=(budgie-desktop-view)
conflicts=(budgie-desktop-view)
-source=("git+https://github.com/getsolus/budgie-desktop-view.git")
+source=("$pkgname"::"git+https://github.com/BuddiesOfBudgie/budgie-desktop-view.git")
md5sums=('SKIP')
pkgver() {
- cd budgie-desktop-view
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare(){
- cd budgie-desktop-view
- meson --prefix=/usr --sysconfdir=/etc build
+ cd "$pkgname"
+ git describe --long --tags | sed -r 's/^v([^-]*)-([^-]*)-/\1.r\2./'
}
build() {
- cd budgie-desktop-view
+ cd "$pkgname"
+ meson build --prefix=/usr --sysconfdir=/etc --buildtype=plain
ninja -C build
}
package() {
- cd budgie-desktop-view
+ cd "$pkgname"
DESTDIR="${pkgdir}" ninja -C build install
}
-