summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2020-11-08 10:01:36 +0100
committerValHue2020-11-08 10:01:36 +0100
commite06e5c66dcb455f3736e9048fd4a5ae8ffb5befe (patch)
treed8143802b3bac1a2e4896ae029ae669d0274def9
parenta76cc142570b5017f83c01e136b13f779f07e281 (diff)
downloadaur-e06e5c66dcb455f3736e9048fd4a5ae8ffb5befe.tar.gz
Fix source
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6697d7389c99..5fd4ce6e5a4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = budgie-lightpad-applet
pkgdesc = A stylish panel applet that displays applications in a fullscreen desktop view.
pkgver = 0.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/UbuntuBudgie/budgie-lightpad-applet
arch = i686
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = budgie-lightpad-applet
depends = libpeas
depends = lightpad
depends = budgie-desktop
- source = budgie-lightpad-applet-0.0.2.zip::https://github.com/UbuntuBudgie/budgie-lightpad-applet/archive/master.zip
- sha256sums = 9c8444aef500343906ce74de347403c21a01e05aa06e71fd30d2f2f0f5b717f8
+ source = budgie-lightpad-applet-0.0.2.tar.xz::https://launchpad.net/~ubuntubudgie/+archive/ubuntu/backports/+sourcefiles/budgie-lightpad-applet/0.0.2+build1~groovy/budgie-lightpad-applet_0.0.2+build1~groovy.tar.xz
+ sha256sums = 08f324a62a3396bffb642092a53d7ca6593c634f882cf58dc12f8de454f2d1fc
pkgname = budgie-lightpad-applet
diff --git a/PKGBUILD b/PKGBUILD
index 2778b149daa6..1282e79465ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,27 @@
#
pkgname="budgie-lightpad-applet"
pkgver="0.0.2"
-pkgrel="1"
+pkgrel="2"
+_launchpad_rel="build1~groovy"
pkgdesc="A stylish panel applet that displays applications in a fullscreen desktop view."
arch=('i686' 'x86_64')
url="https://github.com/UbuntuBudgie/${pkgname}"
+_launchpad_url="https://launchpad.net/~ubuntubudgie/+archive/ubuntu/backports"
license=('GPL3')
depends=('libpeas' 'lightpad' 'budgie-desktop')
makedepends=('gobject-introspection' 'meson' 'ninja' 'vala')
-source=("${pkgname}-${pkgver}.zip::${url}/archive/master.zip")
-sha256sums=('9c8444aef500343906ce74de347403c21a01e05aa06e71fd30d2f2f0f5b717f8')
+source=("${pkgname}-${pkgver}.tar.xz::${_launchpad_url}/+sourcefiles/${pkgname}/${pkgver}+build1~groovy/${pkgname}_${pkgver}+build1~groovy.tar.xz")
+sha256sums=('08f324a62a3396bffb642092a53d7ca6593c634f882cf58dc12f8de454f2d1fc')
build() {
- cd "${srcdir}/${pkgname}-master"
- meson build --prefix=/usr --libdir=/usr/lib
+ cd "${pkgname}-${pkgver}+${_launchpad_rel}"
+ arch-meson build --prefix=/usr --libdir=/usr/lib
ninja -C build
}
package() {
- cd "${srcdir}/${pkgname}-master"
+ cd "${pkgname}-${pkgver}+${_launchpad_rel}"
DESTDIR="${pkgdir}" ninja -C build install
}