summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahuel Gomez Castro2019-09-21 15:00:18 -0300
committerNahuel Gomez Castro2019-09-21 15:00:18 -0300
commit50dd5d01ec1af886f407ce0e08b5132986c205c5 (patch)
tree409e6b4f240b801d3e5c4e7bb3bd4658aa1f28d8
parent705ef080ebd9ea086eb126a214d98dfdafe7c7ac (diff)
downloadaur-50dd5d01ec1af886f407ce0e08b5132986c205c5.tar.gz
Fixes compilation errors with Vala 0.44
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--02-Fixes-compilation-errors-with-Vala-0.44.patch26
-rw-r--r--PKGBUILD48
4 files changed, 63 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28427b5265e8..27feb3f9eaa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = budgie-screenshot-applet
pkgdesc = A Budgie applet for taking and uploading screenshots to Imgur and Imagebin.
pkgver = 0.4.3
- pkgrel = 2
+ pkgrel = 3
+ url = https://github.com/cybre/budgie-screenshot-applet
arch = i686
arch = x86_64
license = GPL2
@@ -14,10 +15,12 @@ pkgbase = budgie-screenshot-applet
depends = budgie-desktop
depends = json-glib
depends = gnome-desktop
- source = https://github.com/cybre/budgie-screenshot-applet/archive/v0.4.3.tar.gz
+ source = git+https://github.com/cybre/budgie-screenshot-applet.git#tag=v0.4.3
source = 01-fix-gtk-3.24-compilation.patch
- sha256sums = 0a39cd01a76aaa825caccd62a46833163e113098f359074171eb134a27c7b67b
+ source = 02-Fixes-compilation-errors-with-Vala-0.44.patch
+ sha256sums = SKIP
sha256sums = 328a13065e28d8d5a8ae623ebb0e5fb3341df5aa082d5d3dfc0630d9abda5704
+ sha256sums = 8c92ea4fb70a76c08337c5aa414669db9a043a197227c7ad6a4c2fda735d8871
pkgname = budgie-screenshot-applet
diff --git a/.gitignore b/.gitignore
index 32493b4b7c76..7b5201d18b5d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
/src
/pkg
-*.tar.gz
+/budgie-screenshot-applet
*.tar.xz
-*.part \ No newline at end of file
diff --git a/02-Fixes-compilation-errors-with-Vala-0.44.patch b/02-Fixes-compilation-errors-with-Vala-0.44.patch
new file mode 100644
index 000000000000..7f90fbb75045
--- /dev/null
+++ b/02-Fixes-compilation-errors-with-Vala-0.44.patch
@@ -0,0 +1,26 @@
+From 0e0c582adedc4105bb6677aa932e3ecc6ca35fc5 Mon Sep 17 00:00:00 2001
+From: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+Date: Thu, 9 May 2019 15:46:52 -0300
+Subject: [PATCH] Fixes compilation errors with Vala 0.44
+
+---
+ src/Backend/Uploader.vala | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Backend/Uploader.vala b/src/Backend/Uploader.vala
+index cc874e7..28feda0 100644
+--- a/src/Backend/Uploader.vala
++++ b/src/Backend/Uploader.vala
+@@ -96,9 +96,9 @@ private class Uploader : GLib.Object
+ return upload_in_progress;
+ }
+
+- public unowned GLib.HashTable<string, weak Providers.IProvider> get_providers() {
++ public unowned GLib.HashTable<string, Providers.IProvider> get_providers() {
+ return upload_providers;
+ }
+ }
+
+-} // End namespace
+\ No newline at end of file
++} // End namespace
diff --git a/PKGBUILD b/PKGBUILD
index 93b9e3208ad8..2f95372145d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,41 @@
-# Maintainer: Carlos Mogas da Silva <r3pek@r3pek.org>
-# Contributer: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
+# Maintainer: Nahuel Gomez Castro <nahual_gomca@outlook.com.ar>
+# Contributor: Carlos Mogas da Silva <r3pek@r3pek.org>
+# Contributor: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
-pkgname=budgie-screenshot-applet
-pkgver=0.4.3
-pkgrel=2
-pkgdesc="A Budgie applet for taking and uploading screenshots to Imgur and Imagebin."
+pkgname='budgie-screenshot-applet'
+pkgver='0.4.3'
+pkgrel='3'
+pkgdesc='A Budgie applet for taking and uploading screenshots to Imgur and Imagebin.'
arch=('i686' 'x86_64')
+url="https://github.com/cybre/${pkgname}"
license=('GPL2')
-depends=('libpeas' 'budgie-desktop' 'json-glib' 'gnome-desktop')
+depends=('libpeas' 'budgie-desktop' 'json-glib' 'gnome-desktop')
makedepends=('intltool' 'meson' 'ninja' 'vala' 'gobject-introspection')
-source=("https://github.com/cybre/${pkgname}/archive/v${pkgver}.tar.gz"
- "01-fix-gtk-3.24-compilation.patch")
-sha256sums=('0a39cd01a76aaa825caccd62a46833163e113098f359074171eb134a27c7b67b'
- '328a13065e28d8d5a8ae623ebb0e5fb3341df5aa082d5d3dfc0630d9abda5704')
+source=("git+${url}.git#tag=v${pkgver}"
+ '01-fix-gtk-3.24-compilation.patch'
+ '02-Fixes-compilation-errors-with-Vala-0.44.patch')
+sha256sums=('SKIP'
+ '328a13065e28d8d5a8ae623ebb0e5fb3341df5aa082d5d3dfc0630d9abda5704'
+ '8c92ea4fb70a76c08337c5aa414669db9a043a197227c7ad6a4c2fda735d8871')
-build() {
- cd "${pkgname}-${pkgver}"
+pkgver () {
+ cd ${pkgname}
+
+ git describe --tags | sed 's/v//; s/-/.r/; s/-/./'
+}
- patch -p1 < "${srcdir}"/01-fix-gtk-3.24-compilation.patch
+prepare () {
+ cd ${pkgname}
- meson builddir --prefix /usr --buildtype=plain
- ninja -C builddir
+ patch -p1 < "${srcdir}/${source[1]}"
+ patch -p1 < "${srcdir}/${source[2]}"
+}
+
+build() {
+ arch-meson ${pkgname} build
+ ninja -C build
}
package() {
- cd "${pkgname}-${pkgver}"
- DESTDIR="${pkgdir}" ninja -C builddir install
+ DESTDIR="${pkgdir}" ninja -C build install
}