summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoria Keung2022-03-21 14:16:43 -0400
committerDoria Keung2022-03-21 14:16:43 -0400
commit14a4a9da624f0cf9fdb93683e873f492fb2de11f (patch)
tree3f95ec2ded5a717987d6ae255174433e9aefdeaa
parent97919885be0305489d5d1bf4011af4bb2e3c6b56 (diff)
downloadaur-14a4a9da624f0cf9fdb93683e873f492fb2de11f.tar.gz
Update to v1.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b033fdd75a9..564ddcb8da82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.1.0.tar.gz
- sha256sums = fdaa543f9da7d4e2c785fa47dfde0567708432f8252ca8362dc0dc1811d902e1
+ source = https://github.com/bufbuild/buf/archive/v1.1.1.tar.gz
+ sha256sums = 506a98a008a5ddbaaed5dd41ac637d9c3317ffb037ff8414baed64610c59ea80
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 53a0af42ff60..6cc0375bc9b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.1.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.1.1.tar.gz")
build() {
- cd ${pkgname}-1.1.0
+ cd ${pkgname}-1.1.1
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.1.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.1.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.1.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.1.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.1.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.1.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.1.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.1.1/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.1.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.1.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.1.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.1.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.1.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.1.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('fdaa543f9da7d4e2c785fa47dfde0567708432f8252ca8362dc0dc1811d902e1')
+sha256sums=('506a98a008a5ddbaaed5dd41ac637d9c3317ffb037ff8414baed64610c59ea80')