summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoshcarp2023-05-19 15:05:40 -0400
committerjoshcarp2023-05-19 15:05:40 -0400
commit4773349947036332c59a6ff4beb152cde5899a63 (patch)
tree2be0a86c9c1c6e2fb2379b8782586e7696856620
parentb282b5dd98748034bc702596bb0fd384803810e4 (diff)
downloadaur-4773349947036332c59a6ff4beb152cde5899a63.tar.gz
Update to v1.19.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 105eb31c0d8f..c62c52a7b0d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.18.0
+ pkgver = 1.19.0
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.18.0.tar.gz
- sha256sums = 5b7cab965af67abd581af167d00399397f8596799a72425c55d96a6e0126b361
+ source = https://github.com/bufbuild/buf/archive/v1.19.0.tar.gz
+ sha256sums = e3cf1521222902d13b4e72f8dcd2f63ec04790324e288b650de6276a0edc7836
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 71ede42b19c0..8f38f6a00e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.18.0
+pkgver=1.19.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.18.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.19.0.tar.gz")
build() {
- cd ${pkgname}-1.18.0
+ cd ${pkgname}-1.19.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -buildvcs=false -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.18.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.18.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.18.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.18.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.18.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.18.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.18.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.19.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.19.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.19.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.19.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.19.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.19.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.19.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('5b7cab965af67abd581af167d00399397f8596799a72425c55d96a6e0126b361')
+sha256sums=('e3cf1521222902d13b4e72f8dcd2f63ec04790324e288b650de6276a0edc7836')