summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Humphries2023-01-13 16:27:42 -0500
committerJosh Humphries2023-01-13 16:27:42 -0500
commit750cab153819df41021b3095779ad79f926fe561 (patch)
tree8bab516b5e0d7e766277e3c39ab6a065de9196db
parent54a52e71ac0743a450723faa443aab0dc16de689 (diff)
downloadaur-750cab153819df41021b3095779ad79f926fe561.tar.gz
Update to v1.12.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2ff78d82b45..03e4cd12d3cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.10.0
+ pkgver = 1.12.0
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.10.0.tar.gz
- sha256sums = 0fb3f1796164f86912e83c2e16c5a5f13d92589969661b1dc6cd6ee7f3670b1d
+ source = https://github.com/bufbuild/buf/archive/v1.12.0.tar.gz
+ sha256sums = b7cc774fb13758500de5d0c5f74b09cf3f6e5597420b7c762e01ed195e102a2d
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 99d5efa9000b..3f142ccae10e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.10.0
+pkgver=1.12.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.10.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.12.0.tar.gz")
build() {
- cd ${pkgname}-1.10.0
+ cd ${pkgname}-1.12.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -buildvcs=false -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.10.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.10.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.10.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.10.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.10.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.10.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.10.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.12.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.12.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.12.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.12.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.12.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.12.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.12.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('0fb3f1796164f86912e83c2e16c5a5f13d92589969661b1dc6cd6ee7f3670b1d')
+sha256sums=('b7cc774fb13758500de5d0c5f74b09cf3f6e5597420b7c762e01ed195e102a2d')