summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Brandhorst2021-12-15 12:35:37 -0500
committerJohan Brandhorst2021-12-15 12:35:37 -0500
commit7c5ca7d91f11bac542f8b9f52b2dcfecf06e1fd0 (patch)
tree67f4811167b254c617128769443cd43dac02b6df
parent37fc7d9ef3effaab8803fa7cdf9d8ce8f06df9f0 (diff)
downloadaur-7c5ca7d91f11bac542f8b9f52b2dcfecf06e1fd0.tar.gz
Update to v1.0.0-rc9
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86bb0de6f122..9328839391d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.0.0rc8
+ pkgver = 1.0.0rc9
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.0.0-rc8.tar.gz
- sha256sums = ba28940c544b76c9bd6a2120ae84dfa3aecb9483f1421755383ac90b5973cbb3
+ source = https://github.com/bufbuild/buf/archive/v1.0.0-rc9.tar.gz
+ sha256sums = 64badcee7c6a6467699cc706dda1e75804982decf7e2dbcfadfe770404e411a8
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index a26e12c9193b..5ac1015cca0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Johan Brandhorst <jbrandhorst@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.0.0rc8
+pkgver=1.0.0rc9
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc8.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc9.tar.gz")
build() {
- cd ${pkgname}-1.0.0-rc8
+ cd ${pkgname}-1.0.0-rc9
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf bash-completion >completion.bash
./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-1.0.0-rc8/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.0.0-rc8/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.0.0-rc8/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.0.0-rc8/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.0.0-rc8/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm755 "${pkgname}-1.0.0-rc9/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0-rc9/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0-rc9/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0-rc9/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0-rc9/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('ba28940c544b76c9bd6a2120ae84dfa3aecb9483f1421755383ac90b5973cbb3')
+sha256sums=('64badcee7c6a6467699cc706dda1e75804982decf7e2dbcfadfe770404e411a8')