summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoria Keung2022-02-17 18:52:08 -0500
committerDoria Keung2022-02-17 18:52:08 -0500
commit913e69862af16e8354edd0f0e2d0123fdc973248 (patch)
tree0581eb49b8495617eaae550958e78dc6c7278c2b
parente2bf270d0b39c6d066ee19317d3d5b0ed1ae18ae (diff)
downloadaur-913e69862af16e8354edd0f0e2d0123fdc973248.tar.gz
Update to v1.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da64896ec472..570c735ac329 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.0.0rc12
+ pkgver = 1.0.0
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.0.0-rc12.tar.gz
- sha256sums = bb218bff534f2926db6f676fd3dcb564ca8e75e28779cfd1eab057c6fba77cd5
+ source = https://github.com/bufbuild/buf/archive/v1.0.0.tar.gz
+ sha256sums = a0e71973b06dedeefcb64f79cbe29d268b7381a93c9e939e849a17e1baceeaee
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 46c22edcc471..287567dd0a30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.0.0rc12
+pkgver=1.0.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc12.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0.tar.gz")
build() {
- cd ${pkgname}-1.0.0-rc12
+ cd ${pkgname}-1.0.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
- ./buf bash-completion >completion.bash
- ./buf zsh-completion >completion.zsh
- ./buf fish-completion >completion.fish
+ ./buf completion bash >completion.bash
+ ./buf completion zsh >completion.zsh
+ ./buf completion fish >completion.fish
mkdir -p manpages
./buf manpages manpages
}
package() {
- install -Dm755 "${pkgname}-1.0.0-rc12/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.0.0-rc12/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.0.0-rc12/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.0.0-rc12/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.0.0-rc12/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.0.0-rc12/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.0.0-rc12/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.0.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.0.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.0.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('bb218bff534f2926db6f676fd3dcb564ca8e75e28779cfd1eab057c6fba77cd5')
+sha256sums=('a0e71973b06dedeefcb64f79cbe29d268b7381a93c9e939e849a17e1baceeaee')