summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Brandhorst2021-09-15 18:44:52 +0000
committerJohan Brandhorst2021-09-15 18:44:52 +0000
commita6f30348f4042a285cd99b6900727bccb8abf32f (patch)
treece5bbfdc2a5e9ceb073cd028830215ba33513d7a
parent1e4fe211c0bc078dab53ea6319ddf20ee64d117c (diff)
downloadaur-a6f30348f4042a285cd99b6900727bccb8abf32f.tar.gz
Update to v1.0.0rc1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08c368abff90..dbadfaf9f29c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 0.56.0
+ pkgver = 1.0.0rc1
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v0.56.0.tar.gz
- sha256sums = 2de1daa261a425541feef05868e66202232d3fc02ab68c2dc353570de015d655
+ source = https://github.com/bufbuild/buf/archive/v1.0.0-rc1.tar.gz
+ sha256sums = 0d0ec20014918ac183c705183b20804e06692bbed6338608674d4591738f32bf
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 757cafd47dc1..bbcf434ddbc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Johan Brandhorst <jbrandhorst@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=0.56.0
+pkgver=1.0.0rc1
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v${pkgver}.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc1.tar.gz")
build() {
- cd ${pkgname}-${pkgver}
- go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-check-lint,protoc-gen-buf-check-breaking}
+ cd ${pkgname}-1.0.0-rc1
+ go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf bash-completion >completion.bash
./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-${pkgver}/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-${pkgver}/protoc-gen-buf-check-lint" "${pkgdir}/usr/bin/protoc-gen-buf-check-lint"
- install -Dm755 "${pkgname}-${pkgver}/protoc-gen-buf-check-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-check-breaking"
- install -Dm644 "${pkgname}-${pkgver}/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-${pkgver}/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm755 "${pkgname}-1.0.0-rc1/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0-rc1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0-rc1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0-rc1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0-rc1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('2de1daa261a425541feef05868e66202232d3fc02ab68c2dc353570de015d655')
+sha256sums=('0d0ec20014918ac183c705183b20804e06692bbed6338608674d4591738f32bf')