summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Brandhorst2021-10-20 15:28:13 -0400
committerJohan Brandhorst2021-10-20 15:28:13 -0400
commitad99a9cbc59a120630979d15e20846cb25b3ae54 (patch)
tree9ac6a3a0892993a055c76c41636dbe020b6c85c4
parenteb185287d0dc8a105cb3101356c5776c531de6c3 (diff)
downloadaur-ad99a9cbc59a120630979d15e20846cb25b3ae54.tar.gz
Update to v1.0.0rc6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdad3df07fea..ad41460b5023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.0.0rc5
+ pkgver = 1.0.0rc6
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.0.0-rc5.tar.gz
- sha256sums = a3ee7c1ceafdf5a2f9451f2a992ad4fd50a5cfb478cb9975df4f5751f64a4428
+ source = https://github.com/bufbuild/buf/archive/v1.0.0-rc6.tar.gz
+ sha256sums = bc45a334de2fa3906d7ec9d68a51e35b2a9811f0908a5c84d59c7b42a550c037
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 9fe439b1e15e..a929ca886f50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Johan Brandhorst <jbrandhorst@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.0.0rc5
+pkgver=1.0.0rc6
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc5.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc6.tar.gz")
build() {
- cd ${pkgname}-1.0.0-rc5
+ cd ${pkgname}-1.0.0-rc6
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf bash-completion >completion.bash
./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-1.0.0-rc5/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.0.0-rc5/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.0.0-rc5/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.0.0-rc5/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.0.0-rc5/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm755 "${pkgname}-1.0.0-rc6/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0-rc6/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0-rc6/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0-rc6/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0-rc6/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('a3ee7c1ceafdf5a2f9451f2a992ad4fd50a5cfb478cb9975df4f5751f64a4428')
+sha256sums=('bc45a334de2fa3906d7ec9d68a51e35b2a9811f0908a5c84d59c7b42a550c037')