summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoria Keung2022-05-30 16:21:28 -0400
committerDoria Keung2022-05-30 16:21:28 -0400
commitc45d11e21bdec856bc1595fcf130454eed552877 (patch)
tree0ae0fce5b7ae957c9cbc310b3fbde0a90cb35038
parent4cf5c8dd22b3c862e42cd9e405de41bea8cd74d6 (diff)
downloadaur-c45d11e21bdec856bc1595fcf130454eed552877.tar.gz
Update to v1.5.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c82eda58579..120ad8107265 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.4.0
+ pkgver = 1.5.0
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.4.0.tar.gz
- sha256sums = 7815a1c4182d2ede5a135ee296e9100d6e929ffdf58a9ab46fc6c15c3d07e815
+ source = https://github.com/bufbuild/buf/archive/v1.5.0.tar.gz
+ sha256sums = c2fb212fe6aa61e5d015dcbf092a75bdb0874fdef90f8b25dfa49de234523383
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 9f76ae720475..05689478cfa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.4.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.5.0.tar.gz")
build() {
- cd ${pkgname}-1.4.0
+ cd ${pkgname}-1.5.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.4.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.4.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.4.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.4.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.4.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.4.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.4.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.5.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.5.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.5.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.5.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.5.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.5.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.5.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('7815a1c4182d2ede5a135ee296e9100d6e929ffdf58a9ab46fc6c15c3d07e815')
+sha256sums=('c2fb212fe6aa61e5d015dcbf092a75bdb0874fdef90f8b25dfa49de234523383')