summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Brandhorst2021-10-19 13:33:23 -0400
committerJohan Brandhorst2021-10-19 13:33:23 -0400
commiteb185287d0dc8a105cb3101356c5776c531de6c3 (patch)
tree06808b6b0f1448089758c77cbedf521e44b44ddf
parentc96b1e542421e3153b25c68b76b1f2d7ca2fcb86 (diff)
downloadaur-eb185287d0dc8a105cb3101356c5776c531de6c3.tar.gz
Update to v1.0.0rc5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07f3aed7c191..fdad3df07fea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.0.0rc4
+ pkgver = 1.0.0rc5
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.0.0-rc4.tar.gz
- sha256sums = b80420af88ef54f9741e2a1c1cadc72db5858a72af932d43a2fc65f830826977
+ source = https://github.com/bufbuild/buf/archive/v1.0.0-rc5.tar.gz
+ sha256sums = a3ee7c1ceafdf5a2f9451f2a992ad4fd50a5cfb478cb9975df4f5751f64a4428
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 470fe330cd33..9fe439b1e15e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Johan Brandhorst <jbrandhorst@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.0.0rc4
+pkgver=1.0.0rc5
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc4.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc5.tar.gz")
build() {
- cd ${pkgname}-1.0.0-rc4
+ cd ${pkgname}-1.0.0-rc5
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf bash-completion >completion.bash
./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-1.0.0-rc4/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.0.0-rc4/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.0.0-rc4/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.0.0-rc4/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.0.0-rc4/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm755 "${pkgname}-1.0.0-rc5/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0-rc5/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0-rc5/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0-rc5/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0-rc5/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('b80420af88ef54f9741e2a1c1cadc72db5858a72af932d43a2fc65f830826977')
+sha256sums=('a3ee7c1ceafdf5a2f9451f2a992ad4fd50a5cfb478cb9975df4f5751f64a4428')