summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Forster2022-05-19 12:01:16 +0100
committerShane Forster2022-05-19 12:01:16 +0100
commit2775b1c3cb500610f0d739f1cea1beedda5668b4 (patch)
treed55d9b05d7ba5b386f47644d49a3be1248ddf7e9
parent2d2f631d717bdd96e84c8d1415588acf3da405d8 (diff)
downloadaur-2775b1c3cb500610f0d739f1cea1beedda5668b4.tar.gz
0.18.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afe03f893666..96dd10a3d0fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = buffalo-bin
pkgdesc = A Go web development ecosystem, designed to make your project easier
- pkgver = 0.18.2
+ pkgver = 0.18.5
pkgrel = 1
url = https://gobuffalo.io
arch = x86_64
license = MIT
- depends = go>=1.13
+ depends = go>=1.16
optdepends = nodejs>=8: frontend support
optdepends = npm: asset pipeline
optdepends = yarn: frontend dependency management
optdepends = gcc: for sqlite3 support
optdepends = git: VCS support
conflicts = buffalo-git
- source = https://github.com/gobuffalo/cli/releases/download/v0.18.2/buffalo_0.18.2_Linux_x86_64.tar.gz
- sha256sums = aad0b2140f679778d7a96ff67862998d2c9955d0d8e5cb088dafffd33eef7a6d
+ source = https://github.com/gobuffalo/cli/releases/download/v0.18.5/buffalo_0.18.5_Linux_x86_64.tar.gz
+ sha256sums = ee7da7486a10c3c2de9e5283d88962ca123d9e4c5c77fa76860e6e5502ef9c5c
pkgname = buffalo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 197a23e97b04..b2b0b3db413c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Cara Salter <cara at devcara dot com>
+# Maintainer: shane4ster <archlinux at sl dot forster dot dev>
+# Contributor: Cara Salter <cara at devcara dot com>
# Contributor: theguy147 <yakamoz147 at protonmail dot com>
# Contributor: Marco Steiger <marco at steiger dot online>
pkgname=buffalo-bin
-pkgver=0.18.2
+pkgver=0.18.5
pkgrel=1
epoch=
pkgdesc="A Go web development ecosystem, designed to make your project easier"
@@ -10,7 +11,7 @@ arch=('x86_64')
url="https://gobuffalo.io"
license=('MIT')
groups=()
-depends=('go>=1.13')
+depends=('go>=1.16')
makedepends=()
checkdepends=()
optdepends=('nodejs>=8: frontend support'
@@ -27,10 +28,10 @@ install=
changelog=
source=("https://github.com/gobuffalo/cli/releases/download/v$pkgver/buffalo_${pkgver}_Linux_x86_64.tar.gz")
noextract=()
-sha256sums=('aad0b2140f679778d7a96ff67862998d2c9955d0d8e5cb088dafffd33eef7a6d')
+sha256sums=('ee7da7486a10c3c2de9e5283d88962ca123d9e4c5c77fa76860e6e5502ef9c5c')
validpgpkeys=()
package() {
cd $srcdir
- install -Dm755 "${srcdir}/buffalo" "${pkgdir}/usr/local/bin/buffalo"
+ install -Dm755 "${srcdir}/buffalo" "${pkgdir}/usr/local/bin/buffalo"
}