summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCara Salter2021-11-18 13:42:27 -0500
committerCara Salter2021-11-18 13:44:37 -0500
commitc4c5e69753b78239389af95fa001e33245b2cc52 (patch)
treedde8cacdd666960bf97704bf6f80d4d64197199b
parent0750b32ce1cfcdd00f09fc0e4374b1b6a89901de (diff)
downloadaur-c4c5e69753b78239389af95fa001e33245b2cc52.tar.gz
0.17.7
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 36 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6372bce38d59..2e2496598e00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = buffalo-bin
- pkgdesc = A Go web development eco-system, designed to make your project easier.
- pkgver = 0.16.23
+ pkgdesc = A Go web development ecosystem, designed to make your project easier
+ pkgver = 0.17.7
pkgrel = 1
- url = https://github.com/gobuffalo/buffalo/
+ url = https://gobuffalo.io
arch = x86_64
license = MIT
- makedepends = tar
depends = go>=1.13
- optdepends = nodejs>=8: frontend
+ optdepends = nodejs>=8: frontend support
optdepends = npm: asset pipeline
optdepends = yarn: frontend dependency management
- optdepends = gcc: for building sqlite3 support
- optdepends = git: for VCS support
+ optdepends = gcc: for sqlite3 support
+ optdepends = git: VCS support
conflicts = buffalo-git
- source = buffalo-bin-0.16.23.tar.gz::https://github.com/gobuffalo/buffalo/releases/download/v0.16.23/buffalo_0.16.23_Linux_x86_64.tar.gz
- sha256sums = 603258ee05ab9b8489bd93f41222132cb0a1ce9c6784c3f066b39af6137daffa
+ source = https://github.com/gobuffalo/cli/releases/download/v0.17.7/buffalo_0.17.7_Linux_x86_64.tar.gz
+ sha256sums = 4c16bde030a6d1c1c44bd398ac64a2496a497db12d43feae1b9361d8edc4fabe
pkgname = buffalo-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 2a80f4196742..81d5ae4a8ef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,36 @@
-# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
-# Contributor: Marco Steiger <marco (at) steiger (dot) online>
+# Maintainer: Cara Salter <cara at devcara dot com>
+# Contributor: theguy147 <yakamoz147 at protonmail dot com>
+# Contributor: Marco Steiger <marco at steiger dot online>
pkgname=buffalo-bin
-pkgver=0.16.23
+pkgver=0.17.7
pkgrel=1
-pkgdesc='A Go web development eco-system, designed to make your project easier.'
+epoch=
+pkgdesc="A Go web development ecosystem, designed to make your project easier"
arch=('x86_64')
-url="https://github.com/gobuffalo/buffalo/"
+url="https://gobuffalo.io"
license=('MIT')
-makedepends=('tar')
+groups=()
depends=('go>=1.13')
-optdepends=('nodejs>=8: frontend'
- 'npm: asset pipeline'
- 'yarn: frontend dependency management'
- 'gcc: for building sqlite3 support'
- 'git: for VCS support')
-conflicts=('buffalo-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gobuffalo/buffalo/releases/download/v${pkgver}/buffalo_${pkgver}_Linux_x86_64.tar.gz")
-sha256sums=('603258ee05ab9b8489bd93f41222132cb0a1ce9c6784c3f066b39af6137daffa')
+makedepends=()
+checkdepends=()
+optdepends=('nodejs>=8: frontend support'
+ 'npm: asset pipeline'
+ 'yarn: frontend dependency management'
+ 'gcc: for sqlite3 support'
+ 'git: VCS support')
+provides=()
+conflicts=("buffalo-git")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/gobuffalo/cli/releases/download/v$pkgver/buffalo_${pkgver}_Linux_x86_64.tar.gz")
+noextract=()
+sha256sums=('4c16bde030a6d1c1c44bd398ac64a2496a497db12d43feae1b9361d8edc4fabe')
+validpgpkeys=()
package() {
- install -Dm755 "${srcdir}/buffalo" "${pkgdir}/usr/bin/buffalo"
+ cd $srcdir
+ install -Dm755 "${srcdir}/buffalo" "${pkgdir}/usr/local/bin/buffalo"
}