summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-08-21 21:44:48 +0000
committerGeorge Rawlinson2021-08-21 21:44:48 +0000
commit09578bb0c28129a30255915b65ab71349fef7e5c (patch)
treeea66f29846e215381b52908708efa2e9970ca8d1
parent4804ccb6c71b7b9b10301f0c4ec10aa5a56d64f5 (diff)
downloadaur-09578bb0c28129a30255915b65ab71349fef7e5c.tar.gz
upgpkg: bugdom 1.3.1-1
* New upstream release. * Add more documentation.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD44
2 files changed, 25 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05c422af88f5..af42bc37af9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bugdom
pkgdesc = Save Bugdom from Thorax's evil Fire Ants
- pkgver = 1.3.0
- pkgrel = 2
+ pkgver = 1.3.1
+ pkgrel = 1
url = https://github.com/jorio/Bugdom
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
@@ -10,16 +10,13 @@ pkgbase = bugdom
depends = sdl2
depends = glu
depends = hicolor-icon-theme
- source = bugdom::git+https://github.com/jorio/Bugdom.git#tag=1.3.0
+ source = bugdom::git+https://github.com/jorio/Bugdom.git#tag=1.3.1
source = git+https://github.com/jorio/Pomme.git
- source = git+https://github.com/jorio/Quesa.git
source = bugdom.desktop
source = bugdom.sh
b2sums = SKIP
b2sums = SKIP
- b2sums = SKIP
b2sums = f8c230b4047950d3f5f733e795b6ea0082a59348bdf44716ed027f0b7ccd1472c5663f8c8dc19e4548a0cc628c17ffa1f52a5011eb6ee70a33afbeae4a2e9e8c
b2sums = 62176cb077576d5274818dfe1d297856ed2d284a7e137dda812682758655275a476c7449ec9d51929c6fbf804f1fea789e91d241ee7ffd14e9b02c418bc097ff
pkgname = bugdom
-
diff --git a/PKGBUILD b/PKGBUILD
index 566f9acebe7b..4d72f7008751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
pkgname=bugdom
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.3.1
+pkgrel=1
pkgdesc="Save Bugdom from Thorax's evil Fire Ants"
-arch=(x86_64)
+arch=('x86_64')
url="https://github.com/jorio/Bugdom"
license=('custom:CC-BY-NC-SA-4.0')
-depends=(sdl2 glu hicolor-icon-theme)
-makedepends=(cmake git)
-source=("$pkgname::git+$url.git#tag=$pkgver"
- "git+https://github.com/jorio/Pomme.git"
- "git+https://github.com/jorio/Quesa.git"
- "$pkgname.desktop"
- "$pkgname.sh")
+depends=('sdl2' 'glu' 'hicolor-icon-theme')
+makedepends=('cmake' 'git')
+source=(
+ "$pkgname::git+$url.git#tag=$pkgver"
+ 'git+https://github.com/jorio/Pomme.git'
+ "$pkgname.desktop"
+ "$pkgname.sh"
+)
b2sums=('SKIP'
'SKIP'
- 'SKIP'
'f8c230b4047950d3f5f733e795b6ea0082a59348bdf44716ed027f0b7ccd1472c5663f8c8dc19e4548a0cc628c17ffa1f52a5011eb6ee70a33afbeae4a2e9e8c'
'62176cb077576d5274818dfe1d297856ed2d284a7e137dda812682758655275a476c7449ec9d51929c6fbf804f1fea789e91d241ee7ffd14e9b02c418bc097ff')
@@ -24,7 +24,6 @@ prepare() {
cd "$pkgname"
git submodule init
git config submodule.Pomme.url ../Pomme
- git config submodule.Quesa.url ../Quesa
git submodule update
cmake -S . -B build \
-DCMAKE_BUILD_TYPE=None \
@@ -40,24 +39,25 @@ build() {
package() {
cd "$pkgname"
- # create dirs
- install -d "$pkgdir/usr/lib/$pkgname" "$pkgdir/usr/share/doc/$pkgname"
-
# move binary & assets
- mv build/{Data,Bugdom} "$pkgdir/usr/lib/$pkgname"
+ install -vd "$pkgdir/usr/lib/$pkgname"
+ mv -v build/{Data,Bugdom} "$pkgdir/usr/lib/$pkgname"
# wrapper script for $PATH execution
- install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -vDm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
# desktop file & icon
- install -Dm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
- install -Dm644 \
- "$srcdir/$pkgname/cmake/Bugdom512.png" \
+ install -vDm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
+ install -vDm644 packaging/Bugdom512.png \
"$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
# documentation
- cp "$srcdir/$pkgname/"docs/* "$pkgdir/usr/share/doc/$pkgname"
+ install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" *.md
+ rm -vf "$pkgdir/usr/share/doc/$pkgname/LICENSE.md"
+ cp -vr docs "$pkgdir/usr/share/doc/$pkgname"
+ sed -e "s/@PROJECT_VERSION@/$pkgver/" packaging/ReadMe.txt.in \
+ > "$pkgdir/usr/share/doc/$pkgname/README"
# license
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/$pkgname/LICENSE.md"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md
}