summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-05-22 20:21:13 +1200
committerGeorge Rawlinson2023-05-22 20:21:13 +1200
commit6b55b18326e1cd64d86add1be8486bb5b2a88110 (patch)
tree501998805954876a60d1cbc14aeb3decfb7c6ffd
parent771dfa61550d9eda809f4decf2a794112f7f4f53 (diff)
downloadaur-6b55b18326e1cd64d86add1be8486bb5b2a88110.tar.gz
fix: gcc 13 ftbfs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fe80c9c5f8c..e6f1c02e3c3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bugdom
pkgdesc = Save Bugdom from Thorax's evil Fire Ants
pkgver = 1.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jorio/Bugdom
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
@@ -11,7 +11,7 @@ pkgbase = bugdom
depends = glu
depends = hicolor-icon-theme
source = bugdom::git+https://github.com/jorio/Bugdom.git#commit=85e88ea7cde3cd63f94fbd0cac6358f7d33b1c66
- source = git+https://github.com/jorio/Pomme.git
+ source = github.com-jorio-Pomme::git+https://github.com/jorio/Pomme
source = bugdom.desktop
source = bugdom.sh
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6375e9bd0236..8de1e44bc463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bugdom
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Save Bugdom from Thorax's evil Fire Ants"
arch=('x86_64')
url='https://github.com/jorio/Bugdom'
@@ -12,7 +12,7 @@ makedepends=('cmake' 'git')
_commit='85e88ea7cde3cd63f94fbd0cac6358f7d33b1c66'
source=(
"$pkgname::git+$url.git#commit=$_commit"
- 'git+https://github.com/jorio/Pomme.git'
+ 'github.com-jorio-Pomme::git+https://github.com/jorio/Pomme'
"$pkgname.desktop"
"$pkgname.sh"
)
@@ -29,17 +29,27 @@ pkgver() {
prepare() {
cd "$pkgname"
+
+ # setup git submodules
git submodule init
- git config submodule.Pomme.url ../Pomme
- git submodule update
- cmake -S . -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -Wno-dev
+ git config submodule.Pomme.url "$srcdir/github.com-jorio-Pomme"
+ git -c protocol.file.allow=always submodule update
+
+ # ftbfs: gcc 13 & cstdint headers
+ cd extern/Pomme
+ git cherry-pick --no-commit d57c28e205462e51063e787f9ebddaadff592f1e
}
build() {
cd "$pkgname"
+
+ cmake \
+ -S . \
+ -B build \
+ -D CMAKE_BUILD_TYPE=None \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -W no-dev
+
cmake --build build
}