summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2020-05-07 16:39:04 +0200
committerDaniel Nagy2020-05-07 17:16:27 +0200
commit751ca4c03ca5a5bb96dbad96216fc88d764269aa (patch)
treecc38523487c6524fe3ddc2f4457ba559f2858cb6
downloadaur-751ca4c03ca5a5bb96dbad96216fc88d764269aa.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16a10c752ae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bugit-git
+ pkgdesc = BuGit: File-less distributed bug tracking system with Git
+ pkgver = r82.381a3e8
+ pkgrel = 1
+ url = https://gitlab.com/monnier/bugit
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = git
+ provides = bugit
+ conflicts = bugit
+ source = git+https://gitlab.com/monnier/bugit
+ sha256sums = SKIP
+
+pkgname = bugit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7de8d9cc5f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daniel Nagy <danielnagy@posteo.de>
+pkgname=bugit-git
+pkgver=r82.381a3e8
+pkgrel=1
+pkgdesc="BuGit: File-less distributed bug tracking system with Git"
+arch=('any')
+url="https://gitlab.com/monnier/bugit"
+license=('GPL3')
+groups=()
+depends=("git")
+makedepends=("git")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://gitlab.com/monnier/bugit')
+noextract=()
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D -m755 bugit "$pkgdir"/usr/bin/bugit
+}