summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Castelli2019-05-03 16:04:29 -0700
committerLorenzo Castelli2019-05-03 16:04:29 -0700
commit38399480b93d28b7652f6eb4cbf631d3a6488ee9 (patch)
tree67be713274789607b6c961cfddfda59ac63d5ef3
downloadaur-38399480b93d28b7652f6eb4cbf631d3a6488ee9.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc5e5255d656
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = build-arch-gce
+ pkgdesc = Builds an Arch image for Google Compute Engine
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/GoogleCloudPlatform/compute-archlinux-image-builder
+ arch = any
+ license = Apache
+ depends = arch-install-scripts
+ depends = e2fsprogs
+ source = build-arch-gce-0.2.tar.gz::https://github.com/GoogleCloudPlatform/compute-archlinux-image-builder/archive/0.2.tar.gz
+ sha256sums = 20ad92fa62d00cd48a47ce164efc9a4fc7e4609ce7da67049a942e452f97fa6f
+
+pkgname = build-arch-gce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cade5030d69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Copyright 2018 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Maintainer: Lorenzo Castelli <lcastelli@google.com>
+# Maintainer: Samuel Littley <samuellittley@google.com>
+
+pkgname='build-arch-gce'
+pkgver=0.2
+pkgrel=1
+pkgdesc='Builds an Arch image for Google Compute Engine'
+arch=('any')
+url='https://github.com/GoogleCloudPlatform/compute-archlinux-image-builder'
+license=('Apache')
+depends=('arch-install-scripts' 'e2fsprogs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/compute-archlinux-image-builder/archive/0.2.tar.gz")
+sha256sums=('20ad92fa62d00cd48a47ce164efc9a4fc7e4609ce7da67049a942e452f97fa6f')
+
+package() {
+ cd "compute-archlinux-image-builder-$pkgver"
+ install -m755 -Dt "$pkgdir/usr/bin/" build-arch-gce
+}