summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2022-05-23 10:14:26 +0200
committerMiguel Revilla2022-05-23 10:14:26 +0200
commit4424cce8e2f4d87fa54b1b53a354dec7d784e8f9 (patch)
tree4161ae3ef1ca9143a7518302ed43e24cc41ded2a
parentb6aee4bc327c63aa9df463f9ebc3fe9cd660ff26 (diff)
downloadaur-4424cce8e2f4d87fa54b1b53a354dec7d784e8f9.tar.gz
Bump to 0.14.0-2. Compiles with GCC 12.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0a8e7cc10a8..dfba1c72d1b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = build2
pkgdesc = build2 build system
pkgver = 0.14.0
- pkgrel = 1
+ pkgrel = 2
url = https://build2.org/
arch = i686
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = build2
makedepends = wget
depends = sqlite3
depends = pkgconf
+ options = !ccache
source = https://download.build2.org/0.14.0/build2-toolchain-0.14.0.tar.xz
source = build.patch
sha256sums = 18efc6b2d41498f7516e7a8a5c91023f6182c867d423792398390dd0c004cfdd
diff --git a/PKGBUILD b/PKGBUILD
index eeb972e63691..d5277a8cbfff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,12 @@
pkgname=build2
pkgver=0.14.0
-pkgrel=1
+pkgrel=2
pkgdesc="build2 build system"
arch=(i686 x86_64)
url="https://build2.org/"
license=('MIT')
+options=('!ccache')
makedepends=('wget')
depends=('sqlite3' 'pkgconf')
source=("https://download.build2.org/${pkgver}/build2-toolchain-${pkgver}.tar.xz"
@@ -23,7 +24,7 @@ build() {
patch -p0 < ${srcdir}/build.patch
mkdir -p ${srcdir}/build/usr
- ./build.sh --trust yes --install-dir ${srcdir}/build/usr g++
+ ./build.sh --trust yes --install-dir ${srcdir}/build/usr ${CXX:-g++} $CXXFLAGS
for f in ${srcdir}/build/usr/lib/pkgconfig/*.pc; do sed -i "s|${srcdir}/build||" ${f}; done
}