summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Verri2017-08-21 10:21:00 -0300
committerFilipe Verri2017-08-21 10:21:00 -0300
commita9a65671a6713fe72e92dbdd07528164014191f1 (patch)
treee9e3e4a766983d2235a7e66ac30ec6b0b71573b8
parentefc85ff60aa0e1d9b86500a7f26092ebbd001501 (diff)
downloadaur-a9a65671a6713fe72e92dbdd07528164014191f1.tar.gz
Improved bootstrapping process.
* Do not use bpkg-stage anymore.
-rw-r--r--PKGBUILD55
1 files changed, 15 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f407242de12f..05366bc86184 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,66 +15,41 @@ sha256sums=('7c1749abdd145254fadfe3684567767a785e3f78b094a5850d2c3d152e32a264')
build() {
cd build2-toolchain-0.6.0
- if test -z "$(command -v bpkg && bpkg --version | grep '^bpkg 0.6.0')"
+ if test -z "$(command -v b && b --version | grep '^build2 0.6.0')"
then
cd build2
./bootstrap.sh g++
- build2/b-boot config.cxx=g++ config.bin.lib=static
- mv build2/b build2/b-boot
-
- mkdir "$srcdir/root"
-
cd ..
- build2/build2/b-boot configure \
- config.cxx=g++ \
- config.bin.suffix=-stage \
- config.bin.lib=static \
- config.install.root="$srcdir/root/usr" \
- config.install.data_root=/tmp/build2-stage
-
- build2/build2/b-boot install
-
- export PATH="$srcdir/root/usr/bin:$PATH"
-
- build2/build2/b-boot configure \
- config.cxx=g++ \
- config.cc.coptions=-O3 \
- config.bin.lib=static \
- config.install.root="$srcdir/root/usr"
-
- export BPKGCMD=bpkg-stage
+ export BCMD="$(pwd)/build2/build2/b-boot"
else
- export BPKGCMD=bpkg
+ export BCMD=b
fi
- mkdir -p build2-g++-release
- cd build2-g++-release
+ cd build2
- $BPKGCMD create \
- cc \
+ $BCMD configure \
config.cxx=g++ \
config.cc.coptions=-O3 \
config.bin.lib=shared \
- config.install.root="$pkgdir/usr"
+ config.install.root="$pkgdir/usr" \
+ config.import.libbutl=''
- $BPKGCMD add https://pkg.cppget.org/1/alpha
- $BPKGCMD --trust-yes fetch
- $BPKGCMD build --yes sys:libbutl build2/0.6.0
+ $BCMD 'update(build2/)'
}
package() {
- cd build2-toolchain-0.6.0/build2-g++-release
+ cd build2-toolchain-0.6.0
- if test -z "$(command -v bpkg && bpkg --version | grep '^bpkg 0.6.0')"
+ if test -z "$(command -v b && b --version | grep '^build2 0.6.0')"
then
- export PATH="$srcdir/root/usr/bin:$PATH"
- export BPKGCMD=bpkg-stage
+ export BCMD="$(pwd)/build2/build2/b-boot"
else
- export BPKGCMD=bpkg
+ export BCMD=b
fi
- $BPKGCMD install build2
+ cd build2
+ $BCMD install
mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm644 "$pkgname-0.6.0/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}