summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Verri2017-08-25 19:02:40 -0300
committerFilipe Verri2017-08-25 19:02:40 -0300
commite6b994ef0e1739190f98a7132c962844c1f1254c (patch)
treee30c0aa64abfe7d2eadb4c206242dc5808532d4b
parent6cbb359d0452dd897e0e76096f409db9da4d9589 (diff)
downloadaur-e6b994ef0e1739190f98a7132c962844c1f1254c.tar.gz
New release.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bafed94fb9f2..ee4c466e0d50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = build2
pkgdesc = build2 build system
- pkgver = 0.6.0
+ pkgver = 0.6.1
pkgrel = 1
url = https://build2.org/
arch = i686
arch = x86_64
license = MIT
makedepends = gcc>=4.9
- depends = libbutl=0.6.0
- source = https://download.build2.org/0.6.0/build2-toolchain-0.6.0.tar.gz
- sha256sums = 7c1749abdd145254fadfe3684567767a785e3f78b094a5850d2c3d152e32a264
+ depends = libbutl>=0.6 libbutl<0.7
+ source = https://download.build2.org/0.6.1/build2-toolchain-0.6.1.tar.xz
+ sha256sums = 4c6167e1a041f29f6072c892ec6316fa86ba31f45fce08f2f964d8b11c8db03a
pkgname = build2
diff --git a/PKGBUILD b/PKGBUILD
index 4e67ab171f85..6fd5d19713f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Filipe Verri <filipeverri@gmail.com>
pkgname=build2
-pkgver=0.6.0
+pkgver=0.6.1
pkgrel=1
pkgdesc="build2 build system"
arch=(i686 x86_64)
url="https://build2.org/"
license=('MIT')
-depends=('libbutl=0.6.0')
+depends=('libbutl>=0.6 libbutl<0.7')
makedepends=('gcc>=4.9')
-source=("https://download.build2.org/0.6.0/build2-toolchain-0.6.0.tar.gz")
-sha256sums=('7c1749abdd145254fadfe3684567767a785e3f78b094a5850d2c3d152e32a264')
+source=("https://download.build2.org/$pkgver/build2-toolchain-$pkgver.tar.xz")
+sha256sums=('4c6167e1a041f29f6072c892ec6316fa86ba31f45fce08f2f964d8b11c8db03a')
build() {
- cd build2-toolchain-0.6.0
+ cd build2-toolchain-$pkgver
- if test -z "$(command -v b && b --version | grep '^build2 0.6.0')"
+ if test -z "$(command -v b && b --version | grep '^build2 0\.6\.')"
then
cd build2
if ! test -x build2/b-boot; then
@@ -27,7 +27,7 @@ build() {
export BCMD=b
fi
- cd build2
+ cd $pkgname
$BCMD configure \
config.cxx=g++ \
@@ -36,20 +36,20 @@ build() {
config.install.root="$pkgdir/usr" \
config.import.libbutl=''
- $BCMD 'update(build2/)'
+ $BCMD "update($pkgname/)"
}
package() {
- cd build2-toolchain-0.6.0
+ cd build2-toolchain-$pkgver
- if test -z "$(command -v b && b --version | grep '^build2 0.6.0')"
+ if test -z "$(command -v b && b --version | grep '^build2 0\.6\.')"
then
export BCMD="$(pwd)/build2/build2/b-boot"
else
export BCMD=b
fi
- cd build2
+ cd $pkgname
$BCMD install
mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"