summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron France2015-09-02 20:11:12 +0200
committerAaron France2015-09-02 20:11:32 +0200
commit019fd0352aab2723d8aabc819103e416f09aa037 (patch)
tree0aa719dee4d29aa4f61575c63b24d3bb7fabbfe0
downloadaur-019fd0352aab2723d8aabc819103e416f09aa037.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa4e91e6521a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = buildapp
+ pkgdesc = A nice easy way to build Common Lisp images
+ pkgver = 1.5.5
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = sbcl
+ depends = sbcl
+ provides = buildapp
+ source = https://github.com/xach/buildapp/archive/release-1.5.5.tar.gz
+ md5sums = a60d1f7c349075f358a1bf0bf9d1ba9c
+
+pkgname = buildapp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..50afc80dec5a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/buildapp-1.5.5-1-x86_64.pkg.tar.xz
+/release-1.5.5.tar.gz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0534db363e33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: <aaron.l.france@gmail.com>
+pkgname=buildapp
+pkgver=1.5.5
+pkgrel=1
+epoch=
+pkgdesc="A nice easy way to build Common Lisp images"
+arch=('i686' 'x86_64')
+url=""
+license=('GPL')
+depends=('sbcl')
+makedepends=('sbcl')
+provides=('buildapp')
+source=(https://github.com/xach/$pkgname/archive/release-$pkgver.tar.gz)
+md5sums=('a60d1f7c349075f358a1bf0bf9d1ba9c')
+
+build() {
+ cd "$srcdir/$pkgname-release-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-release-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/usr" install
+}
+
+# vim:set ts=2 sw=2 et: