summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-08-12 22:21:02 +0800
committerChih-Hsuan Yen2018-08-12 22:21:02 +0800
commitf92b8e87574560ef16a8ef396b3a6e03a5f2e822 (patch)
tree33c9e967b52405a610db02d1205982ff66a41d76
parente1331a46364fa4b60bb7a1d09af47793e3416fd4 (diff)
downloadaur-f92b8e87574560ef16a8ef396b3a6e03a5f2e822.tar.gz
refresh the patch
buildbot=build_packages
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--ignore-invalid-escape-sequence.patch11
3 files changed, 23 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49406e741319..7046ef6debb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buildbot-git
pkgdesc = The Continuous Integration Framework
- pkgver = 1.2.0.r43.g55fc75395
- pkgrel = 3
+ pkgver = 1.3.0.r53.g36d2e3332
+ pkgrel = 1
url = https://buildbot.net
arch = any
license = GPL
@@ -14,8 +14,12 @@ pkgbase = buildbot-git
checkdepends = python-pylint
checkdepends = python-pyenchant
checkdepends = flake8
- checkdepends = buildbot-pkg-git=1.2.0.r43.g55fc75395
- checkdepends = buildbot-worker-git=1.2.0.r43.g55fc75395
+ checkdepends = python-txrequests
+ checkdepends = python-setuptools_trial
+ checkdepends = python-pyjade
+ checkdepends = buildbot-pkg-git=1.3.0.r53.g36d2e3332
+ checkdepends = buildbot-worker-git=1.3.0.r53.g36d2e3332
+ checkdepends = openssh
makedepends = git
depends = python-twisted
depends = python-jinja
@@ -27,11 +31,11 @@ pkgbase = buildbot-git
depends = python-autobahn
depends = python-pyjwt
source = git+https://github.com/buildbot/buildbot.git
- source = ignore-invalid-escape-sequence.patch
source = skip-linux-distro-test.patch
+ source = buildbot-py37.patch::https://github.com/buildbot/buildbot/pull/4254.patch
sha256sums = SKIP
- sha256sums = eb85942f5d9f43ed46c8832f318314084dcde2e53f698bf104af28c3a449ef1f
sha256sums = 42fc2a771034c4134006ed18b52916e668aba3e2046b2fe188c7abcb3cffc0a5
+ sha256sums = 78628cff9f91d161f7951f61924ca1e69f5f0ba559c1b397b542de3ca915ed0a
pkgname = buildbot-git
diff --git a/PKGBUILD b/PKGBUILD
index 39ec6b49ba86..60ec03f5330a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=buildbot-git
pkgdesc="The Continuous Integration Framework"
-pkgver=1.2.0.r43.g55fc75395
-pkgrel=3
+pkgver=1.3.0.r53.g36d2e3332
+pkgrel=1
arch=('any')
url="https://buildbot.net"
license=("GPL")
@@ -16,14 +16,17 @@ depends=('python-twisted' 'python-jinja' 'python-zope-interface' 'python-future'
'python-autobahn' 'python-pyjwt')
makedepends=('git')
checkdepends=('python-treq' 'python-boto3' 'python-mock' 'python-moto'
- 'python-lz4' 'python-isort' 'python-pylint' 'python-pyenchant' 'flake8'
- "buildbot-pkg-git=$pkgver" "buildbot-worker-git=$pkgver")
+ 'python-lz4' 'python-isort' 'python-pylint' 'python-pyenchant'
+ 'flake8' 'python-txrequests' 'python-setuptools_trial'
+ 'python-pyjade'
+ "buildbot-pkg-git=$pkgver" "buildbot-worker-git=$pkgver"
+ 'openssh')
source=(git+https://github.com/buildbot/buildbot.git
- ignore-invalid-escape-sequence.patch
- skip-linux-distro-test.patch)
+ skip-linux-distro-test.patch
+ buildbot-py37.patch::https://github.com/buildbot/buildbot/pull/4254.patch)
sha256sums=('SKIP'
- 'eb85942f5d9f43ed46c8832f318314084dcde2e53f698bf104af28c3a449ef1f'
- '42fc2a771034c4134006ed18b52916e668aba3e2046b2fe188c7abcb3cffc0a5')
+ '42fc2a771034c4134006ed18b52916e668aba3e2046b2fe188c7abcb3cffc0a5'
+ '78628cff9f91d161f7951f61924ca1e69f5f0ba559c1b397b542de3ca915ed0a')
pkgver() {
cd buildbot
@@ -36,7 +39,7 @@ pkgver() {
prepare() {
cd buildbot
- patch -Np1 -i ../ignore-invalid-escape-sequence.patch
+ patch -Np1 -i ../buildbot-py37.patch
# This test relies on VERSION_ID field in /etc/os-release. On Arch Linux this
# field is missing.
patch -Np1 -i ../skip-linux-distro-test.patch
@@ -44,7 +47,7 @@ prepare() {
check() {
cd buildbot/master
- TZ=UTC python setup.py test
+ TZ=UTC python setup.py test --rterrors
}
package() {
diff --git a/ignore-invalid-escape-sequence.patch b/ignore-invalid-escape-sequence.patch
deleted file mode 100644
index 610bcde0cd88..000000000000
--- a/ignore-invalid-escape-sequence.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/master/buildbot/test/__init__.py b/master/buildbot/test/__init__.py
-index 331e5c53b..f97f2766a 100644
---- a/master/buildbot/test/__init__.py
-+++ b/master/buildbot/test/__init__.py
-@@ -141,3 +141,6 @@ warnings.filterwarnings('ignore', r"The value of convert_charrefs will become Tr
-
- # Twisted 18.4+ adds a deprecation warning and still use the deprecated API in its own code!
- warnings.filterwarnings('ignore', ".*getClientIP was deprecated.*", DeprecationWarning)
-+
-+# temporarily disable to make tests pass
-+warnings.filterwarnings('ignore', 'invalid escape sequence', DeprecationWarning)