summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-07-20 14:26:24 +0800
committerChih-Hsuan Yen2018-07-20 14:26:24 +0800
commit846002300bc9e94880873891a437163615d7b287 (patch)
treeef225cabd7b0a4c60846f45c7dcf4cbc9791d51a
downloadaur-846002300bc9e94880873891a437163615d7b287.tar.gz
fix check()
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b73c5788f939
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = buildbot-worker-git
+ pkgdesc = Buildbot Worker Daemon
+ pkgver = 1.2.0.r45.gc9d5f87a3
+ pkgrel = 1
+ url = https://buildbot.net
+ arch = any
+ license = GPL
+ checkdepends = python-mock
+ makedepends = git
+ depends = python-twisted
+ depends = python-future
+ source = git+https://github.com/buildbot/buildbot.git
+ sha256sums = SKIP
+
+pkgname = buildbot-worker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54dd6dd0817f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Forked from aur/buildbot. Original contributors:
+# Contributor: xRemaLx <anton.komolov@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=buildbot-worker-git
+pkgver=1.2.0.r45.gc9d5f87a3
+pkgrel=1
+arch=('any')
+url="https://buildbot.net"
+license=("GPL")
+makedepends=('git')
+pkgdesc="Buildbot Worker Daemon"
+depends=('python-twisted' 'python-future')
+checkdepends=('python-mock')
+source=(git+https://github.com/buildbot/buildbot.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd buildbot
+ ( set -o pipefail
+ git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+check() {
+ cd buildbot/worker
+ PYTHONPATH=. trial3 buildbot_worker
+}
+
+package() {
+ cd buildbot/worker
+ python setup.py install --root="$pkgdir" --optimize=1
+}