summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-07-03 03:19:00 +0800
committerChih-Hsuan Yen2018-07-03 03:19:00 +0800
commit035ce8f531ca18d781a5c520ecc7936fc1d56ba6 (patch)
tree7c14911eeac528e29f105b630777fe219a1e261d
downloadaur-035ce8f531ca18d781a5c520ecc7936fc1d56ba6.tar.gz
new package
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD67
2 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..555c5156b201
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = buildbot-www-git
+ pkgver = 1.2.0.r40.g16dff07ce
+ pkgrel = 1
+ url = https://buildbot.net
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = buildbot-git=1.2.0.r40.g16dff07ce
+ makedepends = buildbot-pkg-git=1.2.0.r40.g16dff07ce
+ makedepends = python-mock
+ makedepends = npm
+ makedepends = yarn
+ source = git+https://github.com/buildbot/buildbot.git
+ sha256sums = SKIP
+
+pkgname = python-buildbot-www-git
+ pkgdesc = Buildbot UI
+ depends = buildbot-git=1.2.0.r40.g16dff07ce
+
+pkgname = python-buildbot-waterfall-view-git
+ pkgdesc = Buildbot Waterfall View plugin
+ depends = buildbot-git=1.2.0.r40.g16dff07ce
+
+pkgname = python-buildbot-console-view-git
+ pkgdesc = Buildbot Console View plugin
+ depends = buildbot-git=1.2.0.r40.g16dff07ce
+
+pkgname = python-buildbot-grid-view-git
+ pkgdesc = Buildbot Grid View plugin
+ depends = buildbot-git=1.2.0.r40.g16dff07ce
+
+pkgname = python-buildbot-wsgi-dashboards-git
+ pkgdesc = Buildbot plugin to integrate flask or bottle dashboards to buildbot UI
+ depends = buildbot-git=1.2.0.r40.g16dff07ce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..598954fca598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Forked from aur/buildbot. Original contributors:
+# Contributor: xRemaLx <anton.komolov@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgbase=buildbot-www-git
+pkgname=('python-buildbot-www-git' 'python-buildbot-waterfall-view-git'
+ 'python-buildbot-console-view-git' 'python-buildbot-grid-view-git' 'python-buildbot-wsgi-dashboards-git'
+ )
+pkgver=1.2.0.r40.g16dff07ce
+pkgrel=1
+arch=('any')
+url="https://buildbot.net"
+license=("GPL")
+makedepends=('git' "buildbot-git=$pkgver" "buildbot-pkg-git=$pkgver" 'python-mock' 'npm' 'yarn')
+source=(git+https://github.com/buildbot/buildbot.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd buildbot
+ ( set -o pipefail
+ git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+package_python-buildbot-www-git() {
+ depends=("buildbot-git=$pkgver")
+ pkgdesc="Buildbot UI"
+
+ cd buildbot/www/base
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python-buildbot-waterfall-view-git() {
+ depends=("buildbot-git=$pkgver")
+ pkgdesc="Buildbot Waterfall View plugin"
+
+ cd buildbot/www/waterfall_view
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python-buildbot-console-view-git() {
+ depends=("buildbot-git=$pkgver")
+ pkgdesc="Buildbot Console View plugin"
+
+ cd buildbot/www/console_view
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python-buildbot-grid-view-git() {
+ depends=("buildbot-git=$pkgver")
+ pkgdesc="Buildbot Grid View plugin"
+
+ cd buildbot/www/grid_view
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python-buildbot-wsgi-dashboards-git() {
+ depends=("buildbot-git=$pkgver")
+ pkgdesc="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+
+ cd buildbot/www/wsgi_dashboards
+ python setup.py install --root="$pkgdir" --optimize=1
+}