summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-08-27 10:09:21 +0800
committerChih-Hsuan Yen2018-08-27 10:09:21 +0800
commit2753096ada433eedc0a90ca842b6228d974b9761 (patch)
treef797b2f82a841b5c97c8778b3a650b90f23146b0
parent1aaa247b5f52efe1ed71d0f96944f3fbd42b96ec (diff)
downloadaur-2753096ada433eedc0a90ca842b6228d974b9761.tar.gz
fix license
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 451ed5f4c872..3479b526c678 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,14 @@ pkgbase = buildbot-www-git
pkgrel = 1
url = https://buildbot.net
arch = any
- license = GPL
+ license = GPL2
makedepends = git
- makedepends = buildbot-git=1.3.0.r2.g95fc42ba3
- makedepends = python-buildbot-pkg-git=1.3.0.r2.g95fc42ba3
+ makedepends = buildbot-git
+ makedepends = python-buildbot-pkg-git
makedepends = python-mock
makedepends = npm
makedepends = yarn
- makedepends = python1
+ makedepends = python2
source = git+https://github.com/buildbot/buildbot.git
source = cairosvg2.patch
sha256sums = SKIP
@@ -18,27 +18,27 @@ pkgbase = buildbot-www-git
pkgname = python-buildbot-www-git
pkgdesc = Buildbot UI
- depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = buildbot-git
pkgname = python-buildbot-waterfall-view-git
pkgdesc = Buildbot Waterfall View plugin
- depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = buildbot-git
pkgname = python-buildbot-console-view-git
pkgdesc = Buildbot Console View plugin
- depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = buildbot-git
pkgname = python-buildbot-grid-view-git
pkgdesc = Buildbot Grid View plugin
- depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = buildbot-git
pkgname = python-buildbot-wsgi-dashboards-git
pkgdesc = Buildbot plugin to integrate flask or bottle dashboards to buildbot UI
- depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = buildbot-git
pkgname = python-buildbot-badges-git
pkgdesc = Buildbot badges
- depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = buildbot-git
depends = python-klein
depends = python-cairosvg
depends = python-cairocffi
diff --git a/PKGBUILD b/PKGBUILD
index bbdeefec259b..b6d03752ef0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ pkgver=1.3.0.r2.g95fc42ba3
pkgrel=1
arch=('any')
url="https://buildbot.net"
-license=("GPL")
-makedepends=('git' "buildbot-git=$pkgver" "python-buildbot-pkg-git=$pkgver" 'python-mock' 'npm' 'yarn' 'python1')
+license=("GPL2")
+makedepends=('git' 'buildbot-git' 'python-buildbot-pkg-git' 'python-mock' 'npm' 'yarn' 'python2')
source=(git+https://github.com/buildbot/buildbot.git
cairosvg2.patch)
sha256sums=('SKIP'
@@ -35,7 +35,7 @@ prepare() {
}
package_python-buildbot-www-git() {
- depends=("buildbot-git=$pkgver")
+ depends=('buildbot-git')
pkgdesc="Buildbot UI"
cd buildbot/www/base
@@ -43,7 +43,7 @@ package_python-buildbot-www-git() {
}
package_python-buildbot-waterfall-view-git() {
- depends=("buildbot-git=$pkgver")
+ depends=('buildbot-git')
pkgdesc="Buildbot Waterfall View plugin"
cd buildbot/www/waterfall_view
@@ -51,7 +51,7 @@ package_python-buildbot-waterfall-view-git() {
}
package_python-buildbot-console-view-git() {
- depends=("buildbot-git=$pkgver")
+ depends=('buildbot-git')
pkgdesc="Buildbot Console View plugin"
cd buildbot/www/console_view
@@ -59,7 +59,7 @@ package_python-buildbot-console-view-git() {
}
package_python-buildbot-grid-view-git() {
- depends=("buildbot-git=$pkgver")
+ depends=('buildbot-git')
pkgdesc="Buildbot Grid View plugin"
cd buildbot/www/grid_view
@@ -67,7 +67,7 @@ package_python-buildbot-grid-view-git() {
}
package_python-buildbot-wsgi-dashboards-git() {
- depends=("buildbot-git=$pkgver")
+ depends=('buildbot-git')
pkgdesc="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
cd buildbot/www/wsgi_dashboards
@@ -75,7 +75,7 @@ package_python-buildbot-wsgi-dashboards-git() {
}
package_python-buildbot-badges-git() {
- depends=("buildbot-git=$pkgver" 'python-klein' 'python-cairosvg' 'python-cairocffi' 'python-jinja')
+ depends=('buildbot-git' 'python-klein' 'python-cairosvg' 'python-cairocffi' 'python-jinja')
pkgdesc="Buildbot badges"
cd buildbot/www/badges