summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-07-16 23:36:32 +0800
committerChih-Hsuan Yen2018-07-16 23:36:32 +0800
commite0120ce31679f55e915869ea50292c8e79904022 (patch)
tree969c5d5d921a9e2de96c3099923985a173ee62b3
parent035ce8f531ca18d781a5c520ecc7936fc1d56ba6 (diff)
downloadaur-e0120ce31679f55e915869ea50292c8e79904022.tar.gz
allow cairosvg2, the one in [community]
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD24
-rw-r--r--cairosvg2.patch13
3 files changed, 51 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 555c5156b201..41e5bbd163d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,45 @@
pkgbase = buildbot-www-git
- pkgver = 1.2.0.r40.g16dff07ce
+ pkgver = 1.3.0.r2.g95fc42ba3
pkgrel = 1
url = https://buildbot.net
arch = any
license = GPL
makedepends = git
- makedepends = buildbot-git=1.2.0.r40.g16dff07ce
- makedepends = buildbot-pkg-git=1.2.0.r40.g16dff07ce
+ makedepends = buildbot-git=1.3.0.r2.g95fc42ba3
+ makedepends = buildbot-pkg-git=1.3.0.r2.g95fc42ba3
makedepends = python-mock
makedepends = npm
makedepends = yarn
source = git+https://github.com/buildbot/buildbot.git
+ source = cairosvg2.patch
sha256sums = SKIP
+ sha256sums = efb460cb040cfd2438d63df51cc7ffd93444dd9d6e1b172f870f4ffce5bafda8
pkgname = python-buildbot-www-git
pkgdesc = Buildbot UI
- depends = buildbot-git=1.2.0.r40.g16dff07ce
+ depends = buildbot-git=1.3.0.r2.g95fc42ba3
pkgname = python-buildbot-waterfall-view-git
pkgdesc = Buildbot Waterfall View plugin
- depends = buildbot-git=1.2.0.r40.g16dff07ce
+ depends = buildbot-git=1.3.0.r2.g95fc42ba3
pkgname = python-buildbot-console-view-git
pkgdesc = Buildbot Console View plugin
- depends = buildbot-git=1.2.0.r40.g16dff07ce
+ depends = buildbot-git=1.3.0.r2.g95fc42ba3
pkgname = python-buildbot-grid-view-git
pkgdesc = Buildbot Grid View plugin
- depends = buildbot-git=1.2.0.r40.g16dff07ce
+ depends = buildbot-git=1.3.0.r2.g95fc42ba3
pkgname = python-buildbot-wsgi-dashboards-git
pkgdesc = Buildbot plugin to integrate flask or bottle dashboards to buildbot UI
- depends = buildbot-git=1.2.0.r40.g16dff07ce
+ depends = buildbot-git=1.3.0.r2.g95fc42ba3
+
+pkgname = python-buildbot-badges-git
+ pkgdesc = Buildbot badges
+ depends = buildbot-git=1.3.0.r2.g95fc42ba3
+ depends = python-klein
+ depends = python-cairosvg
+ depends = python-cairocffi
+ depends = python-jinja
diff --git a/PKGBUILD b/PKGBUILD
index 598954fca598..efc3807da6f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,19 @@
pkgbase=buildbot-www-git
pkgname=('python-buildbot-www-git' 'python-buildbot-waterfall-view-git'
- 'python-buildbot-console-view-git' 'python-buildbot-grid-view-git' 'python-buildbot-wsgi-dashboards-git'
+ 'python-buildbot-console-view-git' 'python-buildbot-grid-view-git'
+ 'python-buildbot-wsgi-dashboards-git' 'python-buildbot-badges-git'
)
-pkgver=1.2.0.r40.g16dff07ce
+pkgver=1.3.0.r2.g95fc42ba3
pkgrel=1
arch=('any')
url="https://buildbot.net"
license=("GPL")
makedepends=('git' "buildbot-git=$pkgver" "buildbot-pkg-git=$pkgver" 'python-mock' 'npm' 'yarn')
-source=(git+https://github.com/buildbot/buildbot.git)
-sha256sums=('SKIP')
+source=(git+https://github.com/buildbot/buildbot.git
+ cairosvg2.patch)
+sha256sums=('SKIP'
+ 'efb460cb040cfd2438d63df51cc7ffd93444dd9d6e1b172f870f4ffce5bafda8')
pkgver() {
cd buildbot
@@ -25,6 +28,11 @@ pkgver() {
)
}
+prepare() {
+ cd buildbot
+
+ patch -Np1 -i ../cairosvg2.patch
+}
package_python-buildbot-www-git() {
depends=("buildbot-git=$pkgver")
@@ -65,3 +73,11 @@ package_python-buildbot-wsgi-dashboards-git() {
cd buildbot/www/wsgi_dashboards
python setup.py install --root="$pkgdir" --optimize=1
}
+
+package_python-buildbot-badges-git() {
+ depends=("buildbot-git=$pkgver" 'python-klein' 'python-cairosvg' 'python-cairocffi' 'python-jinja')
+ pkgdesc="Buildbot badges"
+
+ cd buildbot/www/badges
+ python setup.py install --root="$pkgdir" --optimize=1
+}
diff --git a/cairosvg2.patch b/cairosvg2.patch
new file mode 100644
index 000000000000..cb6d9e4b07b9
--- /dev/null
+++ b/cairosvg2.patch
@@ -0,0 +1,13 @@
+diff --git a/www/badges/setup.py b/www/badges/setup.py
+index dd5261299..739316a01 100644
+--- a/www/badges/setup.py
++++ b/www/badges/setup.py
+@@ -36,7 +36,7 @@ setup_www_plugin(
+ packages=['buildbot_badges'],
+ install_requires=[
+ 'klein',
+- 'CairoSVG==1.0.22', # cairoSVG 2+ is not py2 compatible
++ 'CairoSVG',
+ 'cairocffi', 'Jinja2'
+ ],
+ package_data={