summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Semet2023-12-16 16:17:47 +0100
committerMarko Semet2023-12-16 16:17:47 +0100
commit20d9a6a18a899e2ca1dc90d2f1c4d4c09d987143 (patch)
treef45dce11bfd65f3227078092bda929a092bf36af
parent2362de62b48f5040c3be65a08ae88297dfd5ace1 (diff)
downloadaur-20d9a6a18a899e2ca1dc90d2f1c4d4c09d987143.tar.gz
Update to 1.0.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e9592177692..8633302f58ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buildbox-casd
pkgdesc = Local cache and proxy for remote CAS servers
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
url = https://buildgrid.build
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = buildbox-casd
depends = util-linux-libs
depends = buildbox-common
depends = buildbox-fuse
- source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-casd#tag=1.0.1&commit=d81e215848785dc21d64303e4fca6ef8fa3096cf
+ source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-casd#tag=1.0.2&commit=74ad06be5355c34697158236c42bc7eeb965b21b
sha256sums = SKIP
pkgname = buildbox-casd
diff --git a/PKGBUILD b/PKGBUILD
index 326c2cadeb6e..75fc90fe1500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
# Maintainer: Marko Semet <marko10_000@mailbox.org>
pkgname=buildbox-casd
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="Local cache and proxy for remote CAS servers"
arch=(x86_64)
@@ -9,15 +9,14 @@ url="https://buildgrid.build"
license=('Apache')
depends=(google-glog grpc util-linux-libs 'buildbox-common' 'buildbox-fuse')
makedepends=(benchmark 'cmake' 'git' ninja)
-source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-casd#tag=1.0.1&commit=d81e215848785dc21d64303e4fca6ef8fa3096cf")
+source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-casd#tag=${pkgver}&commit=74ad06be5355c34697158236c42bc7eeb965b21b")
sha256sums=('SKIP')
build() {
mkdir -p build
cd build
- CXXFLAGS="-flto=auto -O2 -ffunction-sections -Wl,--gc-sections" cmake ../buildbox-casd \
+ CXXFLAGS="-flto=auto -flto-partition=one -fuse-linker-plugin -fno-fat-lto-objects -O2 -ffunction-sections -Wl,--gc-sections ${CXXFLAGS}" cmake ../buildbox-casd \
-G Ninja \
- -DCMAKE_CXX_FLAGS=-Wno-error=restrict \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
ninja