summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Semet2023-08-27 18:57:01 +0200
committerMarko Semet2023-08-27 18:57:01 +0200
commit115a5af184527e61b85205b15680f7495ab716d8 (patch)
tree2af80cc9d10c062680f461ef70976abdf68f4877
parentb588d5fd88d020efad499b1255608474a63cb261 (diff)
downloadaur-115a5af184527e61b85205b15680f7495ab716d8.tar.gz
Update to 1.0.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b36ccb5fc0f..979fb36e9c4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buildbox-common
pkgdesc = Shared protocol-buffer definitions and various helper functions
- pkgver = 1.0.0
+ pkgver = 1.0.2
pkgrel = 1
url = https://buildgrid.build
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = buildbox-common
depends = google-glog
depends = grpc
depends = gtest
- source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.0&commit=1be05b3d6a089d4f367ebc56f914fc1a9fdd117d
+ source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.2&commit=4729bf8e7d633f0402066415e121c96bc3ca9a1f
sha256sums = SKIP
pkgname = buildbox-common
diff --git a/PKGBUILD b/PKGBUILD
index 5ecad41cdfe1..07744ab30e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
# Maintainer: Marko Semet <marko10_000@mailbox.org>
pkgname=buildbox-common
-pkgver=1.0.0
+pkgver=1.0.2
pkgrel=1
pkgdesc="Shared protocol-buffer definitions and various helper functions"
arch=(x86_64)
@@ -9,13 +9,14 @@ url="https://buildgrid.build"
license=('Apache')
depends=('gflags' 'google-glog' 'grpc' 'gtest')
makedepends=('benchmark' 'c-ares' 'cmake' 'git' 'gmock' ninja)
-source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.0&commit=1be05b3d6a089d4f367ebc56f914fc1a9fdd117d")
+source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.2&commit=4729bf8e7d633f0402066415e121c96bc3ca9a1f")
sha256sums=('SKIP')
build() {
mkdir -p build
cd build
- cmake ../buildbox-common \
+ sed -i 's/STATIC/SHARED/' ../buildbox-common/CMakeLists.txt
+ CXXFLAGS="-flto=auto -O2 -ffunction-sections -Wl,--gc-sections" cmake ../buildbox-common \
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -24,8 +25,8 @@ build() {
check() {
cd build
- echo "Sometimes 'streamingstandardoutputinotifyfilemonitor' fails, just rerun it."
- ninja test
+ echo "Sometimes 'executionstatsutils_tests' and 'streamingstandardoutputinotifyfilemonitor' fails, just rerun it."
+ CTEST_OUTPUT_ON_FAILURE=True ninja test
}
package() {