summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2020-07-09 11:34:15 -0300
committerRafael Fontenelle2020-07-09 11:34:31 -0300
commit67bae54f781b7896caaa523d0a9c29f9b2663c23 (patch)
treea11368c88e6dd5e5eb21ccf1da5eeb66bc93d94a
parent5e5792827fac3c68c7fa059431dc4a57a8fed797 (diff)
downloadaur-67bae54f781b7896caaa523d0a9c29f9b2663c23.tar.gz
Update to 0.0.12.r0.g897b341
And get version with --long combined with --tags
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b1fee8587ce..1276fae50beb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buildbox-common
pkgdesc = Shared protocol-buffer definitions and various helper functions
- pkgver = 0.0.11.r0.gc696992
+ pkgver = 0.0.12.r0.g897b341
pkgrel = 1
url = https://buildgrid.build
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = buildbox-common
depends = grpc
depends = gtest
depends = gmock
- source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#commit=c69699234660e418274e9f4a50f4558c446fda1e
+ source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#commit=897b341620549fcafc25dbe464eaab682d7ebf89
sha256sums = SKIP
pkgname = buildbox-common
diff --git a/PKGBUILD b/PKGBUILD
index 46d499128a9f..65d0050c5a83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=buildbox-common
-pkgver=0.0.11.r0.gc696992
+pkgver=0.0.12.r0.g897b341
pkgrel=1
pkgdesc="Shared protocol-buffer definitions and various helper functions"
arch=(x86_64)
@@ -8,18 +8,13 @@ url="https://buildgrid.build"
license=('Apache')
depends=('grpc' 'gtest' 'gmock')
makedepends=('cmake' 'git')
-_commit=c69699234660e418274e9f4a50f4558c446fda1e # tag 0.0.11
+_commit=897b341620549fcafc25dbe464eaab682d7ebf89 # tag 0.0.12
source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- # https://gitlab.com/BuildGrid/buildbox/buildbox-common/-/issues/71
- sed -i 's#O_WRONLY);#O_WRONLY, S_IRUSR|S_IWUSR);#' $pkgname/buildbox-common/buildboxcommon/buildboxcommon_systemutils.cpp
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {