summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Semet2023-12-16 16:18:25 +0100
committerMarko Semet2023-12-16 16:18:25 +0100
commit693d775fb43f6949ff6b40a5c0a5116ea79a58ea (patch)
tree8cb3545e1d6ba93d155b3b87285c4e60814b1914
parent0ff658fca0b88ff1ee8beb88ed2416c827c7716f (diff)
downloadaur-693d775fb43f6949ff6b40a5c0a5116ea79a58ea.tar.gz
Update to 1.0.7
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 976421c8f279..c97e883b6651 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buildbox-common
pkgdesc = Shared protocol-buffer definitions and various helper functions
- pkgver = 1.0.4
+ pkgver = 1.0.7
pkgrel = 1
url = https://buildgrid.build
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = buildbox-common
depends = google-glog
depends = grpc
depends = gtest
- source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.4&commit=6e70ed24cfc654031308f7b7b99ed68f649562cd
+ source = git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.7&commit=b1dc0fcf59ae0cb131f632484d3cd6dbc87fdeed
sha256sums = SKIP
pkgname = buildbox-common
diff --git a/PKGBUILD b/PKGBUILD
index eaab5cee6db8..26a22f73e28c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
# Maintainer: Marko Semet <marko10_000@mailbox.org>
pkgname=buildbox-common
-pkgver=1.0.4
+pkgver=1.0.7
pkgrel=1
pkgdesc="Shared protocol-buffer definitions and various helper functions"
arch=(x86_64)
@@ -9,14 +9,14 @@ url="https://buildgrid.build"
license=('Apache')
depends=('gflags' 'google-glog' 'grpc' 'gtest')
makedepends=('benchmark' 'c-ares' 'cmake' 'git' 'gmock' ninja)
-source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=1.0.4&commit=6e70ed24cfc654031308f7b7b99ed68f649562cd")
+source=("git+https://gitlab.com/BuildGrid/buildbox/buildbox-common#tag=${pkgver}&commit=b1dc0fcf59ae0cb131f632484d3cd6dbc87fdeed")
sha256sums=('SKIP')
build() {
mkdir -p build
cd build
sed -i 's/STATIC/SHARED/' ../buildbox-common/CMakeLists.txt
- CXXFLAGS="-flto=auto -O2 -ffunction-sections -Wl,--gc-sections" cmake ../buildbox-common \
+ CXXFLAGS="-flto=auto -flto-partition=one -fuse-linker-plugin -fno-fat-lto-objects -O2 -ffunction-sections -Wl,--gc-sections ${CXXFLAGS}" cmake ../buildbox-common \
-G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr