summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSid2021-09-19 14:50:40 +0530
committerSid2021-09-19 15:06:35 +0530
commitb9507fbb044842d6a1f93ba4b9dc3b32e8102f6e (patch)
tree501f64df306dbdeb56ba93cd1f07d1ea5d599d49
downloadaur-b9507fbb044842d6a1f93ba4b9dc3b32e8102f6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
-rw-r--r--buildgdx1
-rw-r--r--buildgdx.desktop9
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47852f803107
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = buildgdx
+ pkgdesc = A port of the Build Engine games based on Java's libGDX
+ pkgver = 1.15
+ pkgrel = 1
+ url = http://m210.duke4.net/index.php
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = java-environment=8
+ provides = buildgdx
+ conflicts = buildgdx
+ source = https://m210.duke4.net/index.php/downloads/send/8-java/54-buildgdx.zip
+ source = buildgdx.desktop
+ source = buildgdx
+ sha256sums = SKIP
+ sha256sums = 52e5c860572f0f1e38c6fb2d55221e9dfeaa4b49e89142166634c9934d35f4f5
+ sha256sums = f74ba6eae81693f79434c3f8dec4bca75b51a55b67b5875d4e1dd2340ff55c5c
+
+pkgname = buildgdx
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f054e56f8ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sid <sidpranjale127@protonmail.com>
+# Continuing the work of:
+# Maintainer: Jan Cholasta <jan at cholasta net>
+
+pkgname=buildgdx
+pkgver=1.15
+pkgrel=1
+pkgdesc="A port of the Build Engine games based on Java's libGDX"
+arch=('i686' 'x86_64')
+url='http://m210.duke4.net/index.php'
+license=('GPL')
+depends=('java-environment=8')
+makedepends=('unzip')
+provides=('buildgdx')
+conflicts=('buildgdx')
+source=('https://m210.duke4.net/index.php/downloads/send/8-java/54-buildgdx.zip'
+ 'buildgdx.desktop'
+ 'buildgdx')
+sha256sums=('SKIP'
+ '52e5c860572f0f1e38c6fb2d55221e9dfeaa4b49e89142166634c9934d35f4f5'
+ 'f74ba6eae81693f79434c3f8dec4bca75b51a55b67b5875d4e1dd2340ff55c5c')
+
+package() {
+ install -D -t "$pkgdir"/usr/bin buildgdx
+ install -D -t "$pkgdir"/usr/share/$pkgname "$srcdir"/BuildGDX.jar
+ install -D -t "$pkgdir"/usr/share/applications -m 644 "$srcdir"/buildgdx.desktop
+}
diff --git a/buildgdx b/buildgdx
new file mode 100644
index 000000000000..380fabc89f24
--- /dev/null
+++ b/buildgdx
@@ -0,0 +1 @@
+java -jar /usr/share/buildgdx/BuildGDX.jar
diff --git a/buildgdx.desktop b/buildgdx.desktop
new file mode 100644
index 000000000000..3b046592b986
--- /dev/null
+++ b/buildgdx.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=BuildGDX
+GenericName=BuildGDX is a port of the Build Engine games based on Java's LibGDX framework v1.9.10.
+Icon=build128
+Exec=buildgdx
+Terminal=false
+Categories=Game;ActionGame;