summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:47 -0400
committerKevin MacMartin2015-06-10 00:37:47 -0400
commit8d76b5d10f110d68075a7a274cdda62a5a2033a1 (patch)
tree4ab35428a1587f330bbbc0d54b3209d1304c8868
downloadaur-8d76b5d10f110d68075a7a274cdda62a5a2033a1.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3c4a0b66860
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = buildhosts-git
+ pkgdesc = Download and use custom hosts sources to build /etc/hosts
+ pkgver = 20150202.r9.719a8e7
+ pkgrel = 1
+ url = https://github.com/prurigro/buildhosts
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = curl
+ source = git+https://github.com/prurigro/buildhosts.git
+ sha512sums = SKIP
+
+pkgname = buildhosts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc51ac950256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+_pkgname=buildhosts
+pkgname=$_pkgname-git
+pkgver=20150202.r9.719a8e7
+pkgrel=1
+pkgdesc='Download and use custom hosts sources to build /etc/hosts'
+url='https://github.com/prurigro/buildhosts'
+license=('MIT')
+arch=('any')
+depends=('curl')
+makedepends=('git')
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 p2p-to-hosts "$pkgdir/usr/bin/p2p-to-hosts"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}