summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2021-10-08 03:54:35 -0600
committerBenjamin Denhartog2021-10-08 04:02:21 -0600
commit9a2c0e128ce388bcc691626ec02291120afe24bd (patch)
tree8f109f4aebf3dbe911b378a36ea3bd02c31f0d13
downloadaur-9a2c0e128ce388bcc691626ec02291120afe24bd.tar.gz
feat: initial package release: 4.2.2
Release-Notes: https://github.com/bazelbuild/buildtools/releases/tag/4.2.2 Change-Id: I7296956548724b37a1209f5a5c305427c7a861e7 GitOrigin-RevId: 9262a7cd437d17f4531a0b52935df3af9961c467
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD32
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a97b0d83ef9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = buildifier-bin
+ pkgdesc = A command line tool to format Bazel BUILD files
+ pkgver = 4.2.2
+ pkgrel = 1
+ url = https://github.com/bazelbuild/buildtools
+ arch = x86_64
+ license = Apache
+ source = buildifier-4.2.2::https://github.com/bazelbuild/buildtools/releases/download/4.2.2/buildifier-linux-amd64
+ source = LICENSE-4.2.2::https://raw.githubusercontent.com/bazelbuild/buildtools/4.2.2/LICENSE
+ sha256sums = 3f0e450cd852dbfd89aa2761d85f9fbeb6f0faccfc5d4fbe48952cfe0712922a
+ sha256sums = cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30
+
+pkgname = buildifier-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7ad8a8097f5a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+# package archives, downloaded sources
+*.tar.zst
+LICENSE-*
+buildifier-*
+
+# subfolders, e.g. source and build package trees
+*/**/
+
+# backup files
+*~
+*.bak
+
+# log files from makepkg --log
+*.log
+
+# lockfiles from mkarchchroot+makepkg
+*/*.lock
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5395382210ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
+
+# For ISSUES, REQUESTS, and QUESTIONS:
+# https://github.com/sudoforge/pkgbuilds
+
+pkgname=buildifier-bin
+pkgver=4.2.2
+pkgrel=1
+pkgdesc='A command line tool to format Bazel BUILD files'
+arch=('x86_64')
+license=('Apache')
+url='https://github.com/bazelbuild/buildtools'
+source=(
+ "${pkgname%-bin}-${pkgver}::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux-amd64"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/bazelbuild/buildtools/${pkgver}/LICENSE"
+)
+sha256sums=('3f0e450cd852dbfd89aa2761d85f9fbeb6f0faccfc5d4fbe48952cfe0712922a'
+ 'cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30')
+
+package() {
+ cd "${srcdir}"
+
+ # Install the license file
+ install -D -m 0644 \
+ "${source[1]%%::*}" \
+ "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+
+ # Install the binary
+ install -D -m 0755 \
+ "./${source[0]%%::*}" \
+ "${pkgdir}/usr/bin/${pkgname%-bin}"
+}