summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wadley2018-07-04 14:32:29 -0500
committerTom Wadley2018-07-04 14:42:41 -0500
commitc07ca08277aea67a320c2a0da54eca68977561b7 (patch)
treeceb2bcc00b93e47696693e705d62a0ff5de9b9ac
downloadaur-c07ca08277aea67a320c2a0da54eca68977561b7.tar.gz
Based on the old buildnotify-hg (now buildnotify-git). Upstream now has stable versions, thus this package.
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f704dc11853
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = buildnotify
+ pkgdesc = A system tray based build status notification app for cctray.xml feeds
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/anaynayak/buildnotify
+ arch = any
+ license = GPL3
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-pyqt5
+ depends = python2-pytz
+ depends = python2-dateutil
+ optdepends = python2-keyring: keyring support
+ conflicts = buildnotify-hg
+ replaces = buildnotify-hg
+ source = https://github.com/anaynayak/buildnotify/archive/1.0.4.zip
+ sha256sums = e127928040d0ba0e7d23ce87a127be3b96d92ef67f52297b8a927c98bfcae578
+
+pkgname = buildnotify
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..337bb249d23a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar.xz
+pkg/
+src/
+*.zip
+buildnotify/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d7754175e9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tom Wadley <tom@tomwadley.net>
+
+pkgname=buildnotify
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="A system tray based build status notification app for cctray.xml feeds"
+arch=('any')
+url="https://github.com/anaynayak/buildnotify"
+license=('GPL3')
+depends=('python2' 'python2-pyqt5' 'python2-pytz' 'python2-dateutil')
+optdepends=('python2-keyring: keyring support')
+makedepends=('python2-setuptools')
+conflicts=('buildnotify-hg')
+replaces=('buildnotify-hg')
+source=("https://github.com/anaynayak/buildnotify/archive/${pkgver}.zip")
+sha256sums=('e127928040d0ba0e7d23ce87a127be3b96d92ef67f52297b8a927c98bfcae578')
+
+_installmodule() {
+ pushd "${srcdir}/buildnotify-${pkgver}"
+ /usr/bin/python2 setup.py install --root="${pkgdir}/" --optimize=1
+ popd
+}
+
+package() {
+ _installmodule
+
+ cd "${srcdir}/buildnotify-${pkgver}"
+
+ install -D -m 644 buildnotify.desktop "${pkgdir}/usr/share/applications/buildnotify.desktop"
+ install -D -m 644 buildnotify.svg "${pkgdir}/usr/share/pixmaps/buildnotify.svg"
+}
+
+# vim:set ts=2 sw=2 et: