summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2021-05-19 15:08:22 -0600
committerBenjamin Denhartog2021-05-19 21:56:04 -0600
commit29a4d558a50d496d6fd7871d7493b756b4100500 (patch)
treecebe5e61443a30d65c00d5fcd89b60cf6360fb2b
parentc65c2701e60c28ed92dbf4b7124300f96971e905 (diff)
downloadaur-29a4d558a50d496d6fd7871d7493b756b4100500.tar.gz
feat: standardize PKGBUILDs
This commit brings in several changes: - Adding a comment header indicating the public SoT for the packages - Refactoring packages that build with Bazel to use a Bazelisk binary - Minor other improvements and changes GitOrigin-RevId: 8f688b88aee92af8d9cc15ace1499cc83ded8e25
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b3fd66144d5..9f9a6a78781d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buildozer-bin
pkgdesc = A command line tool to rewrite Bazel BUILD files using standard conventions
pkgver = 4.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bazelbuild/buildtools
arch = x86_64
license = Apache
source = buildozer-4.0.1::https://github.com/bazelbuild/buildtools/releases/download/4.0.1/buildozer-linux-amd64
- source = https://raw.githubusercontent.com/bazelbuild/buildtools/4.0.1/LICENSE
+ source = LICENSE-4.0.1::https://raw.githubusercontent.com/bazelbuild/buildtools/4.0.1/LICENSE
sha256sums = 082aea1df38fe30ce41d955a2cbf309cae8ec386507e0c10cc16f0d9a93e151f
sha256sums = cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30
diff --git a/.gitignore b/.gitignore
index c3b375f1db65..94b184dbc261 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
# package archives, downloaded sources
*.tar.zst
-LICENSE
+LICENSE-*
buildozer-*
# subfolders, e.g. source and build package trees
diff --git a/PKGBUILD b/PKGBUILD
index 2d8d62bc4695..2753fe783a67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
-_pkgname=buildtools
+# For ISSUES, REQUESTS, and QUESTIONS:
+# https://github.com/sudoforge/pkgbuilds
+
pkgname=buildozer-bin
pkgver=4.0.1
-pkgrel=1
-pkgdesc="A command line tool to rewrite Bazel BUILD files using standard conventions"
+pkgrel=2
+pkgdesc='A command line tool to rewrite Bazel BUILD files using standard conventions'
arch=('x86_64')
license=('Apache')
-url="https://github.com/bazelbuild/buildtools"
+url='https://github.com/bazelbuild/buildtools'
source=(
"${pkgname%-bin}-${pkgver}::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux-amd64"
- "https://raw.githubusercontent.com/bazelbuild/buildtools/${pkgver}/LICENSE"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/bazelbuild/buildtools/${pkgver}/LICENSE"
)
sha256sums=('082aea1df38fe30ce41d955a2cbf309cae8ec386507e0c10cc16f0d9a93e151f'
'cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30')
@@ -19,10 +21,12 @@ package() {
cd "${srcdir}"
# Install the license file
- install -D -m 0644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+ install -D -m 0644 \
+ "${source[1]%%::*}" \
+ "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
# Install the binary
install -D -m 0755 \
- "./${pkgname%-bin}-${pkgver}" \
+ "./${source[0]%%::*}" \
"${pkgdir}/usr/bin/${pkgname%-bin}"
}