summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Semet2022-12-27 22:42:54 +0100
committerMarko Semet2022-12-27 22:42:54 +0100
commit52bc3334318640d42f2c0da4890c547199255c66 (patch)
tree5ae65e3b107b0d8d5519db63e88ba1b3e8085493
parent6b9eaf708324dcbaaa0d7d4bb8b5f727462c2e5d (diff)
downloadaur-52bc3334318640d42f2c0da4890c547199255c66.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD32
2 files changed, 35 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b4e4341202..39927b9d448f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = buildstream
pkgdesc = A powerful and flexible software integration toolset
- pkgver = 1.6.1
+ pkgver = 2.0.0
pkgrel = 1
url = https://buildstream.build
- arch = any
- license = LGPL
- makedepends = python-setuptools
+ arch = x86_64
+ license = Apache
makedepends = cython
- depends = bubblewrap
+ makedepends = git
+ makedepends = python-packaging
+ depends = buildbox-casd
+ depends = buildbox-fuse
+ depends = buildbox-run-bubblewrap
+ depends = python
depends = python-click
- depends = python-gobject
+ depends = python-dateutil
depends = python-grpcio
depends = python-jinja
depends = python-pluginbase
@@ -17,15 +21,14 @@ pkgbase = buildstream
depends = python-psutil
depends = python-pyroaring
depends = python-ruamel-yaml
- depends = python-six
+ depends = python-setuptools
depends = python-ujson
- depends = bzr
- depends = git
+ depends = bzip2
+ depends = gzip
depends = lzip
- depends = ostree
- depends = python-arpy
- source = https://download.gnome.org/sources/BuildStream/1.6/BuildStream-1.6.1.tar.xz
- sha256sums = 2ba614e13c0641c28e27dc3c41e5b2418e729a9e39ffc06064b8b713390a6b5c
+ depends = tar
+ depends = xz
+ source = git+https://github.com/apache/buildstream.git#tag=2.0.0&commit=f27bc3bed2bdbb3dfd72fdbfa59a7607d74123a7
+ sha256sums = SKIP
pkgname = buildstream
-
diff --git a/PKGBUILD b/PKGBUILD
index 09aa0aee46e7..cceb073f8389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,19 @@
-# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
+# Maintainer: Marko Semet <marko10_000@mailbox.org>
pkgname=buildstream
-pkgver=1.6.1
+pkgver=2.0.0
pkgrel=1
pkgdesc="A powerful and flexible software integration toolset"
-arch=('any')
+arch=(x86_64)
url="https://buildstream.build"
-license=('LGPL')
+license=('Apache')
depends=(
- bubblewrap
+ buildbox-casd
+ buildbox-fuse
+ buildbox-run-bubblewrap
+ python
python-click
- python-gobject
+ python-dateutil
python-grpcio
python-jinja
python-pluginbase
@@ -17,21 +21,21 @@ depends=(
python-psutil
python-pyroaring
python-ruamel-yaml
- python-six
+ python-setuptools
python-ujson
# specific host site dependencies
- bzr git lzip ostree python-arpy
+ bzip2 gzip lzip tar xz
)
-makedepends=(python-setuptools cython)
-source=("https://download.gnome.org/sources/BuildStream/${pkgver%.*}/BuildStream-$pkgver.tar.xz")
-sha256sums=('2ba614e13c0641c28e27dc3c41e5b2418e729a9e39ffc06064b8b713390a6b5c')
+makedepends=(cython git python-packaging)
+source=("git+https://github.com/apache/buildstream.git#tag=2.0.0&commit=f27bc3bed2bdbb3dfd72fdbfa59a7607d74123a7")
+sha256sums=('SKIP')
build() {
- cd BuildStream-$pkgver
+ cd buildstream
python setup.py build
}
package() {
- cd BuildStream-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd buildstream
+ python setup.py install --root="$pkgdir/" --skip-build
}