summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2018-09-24 14:51:11 -0300
committerRafael Fontenelle2018-09-24 14:51:15 -0300
commit5d383ceb4bd5c3e76efb332d41c72340147a6403 (patch)
treec4143a8e4cf69deced3056847cc8f74f49a9c9cd
parent3303ba8d86c9aa495568ca4119262a87e73f6521 (diff)
downloadaur-5d383ceb4bd5c3e76efb332d41c72340147a6403.tar.gz
Update to 1.2.2
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD8
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6580595aca70..aaa7d3bb85af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = buildstream
pkgdesc = Framework for modelling build pipelines in a declarative YAML format
- pkgver = 1.2.1
+ pkgver = 1.2.2
pkgrel = 1
url = https://wiki.gnome.org/Projects/BuildStream/
arch = any
@@ -20,8 +20,8 @@ pkgbase = buildstream
depends = git
depends = lzip
depends = python-arpy
- source = https://download.gnome.org/sources/BuildStream/1.2/BuildStream-1.2.1.tar.xz
- sha256sums = 04333fe9e09f69f00d5e6da0aff109f9620e84d624be88082965847eabdb4305
+ source = https://download.gnome.org/sources/BuildStream/1.2/BuildStream-1.2.2.tar.xz
+ sha256sums = dd0b04e239c362e7ac44e202874da6e9ebfaaad038db513b9af3d57904f77e91
pkgname = buildstream
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aace9926737
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
index 74dbf8a491ec..d32c407e73df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=buildstream
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=1
pkgdesc="Framework for modelling build pipelines in a declarative YAML format"
arch=('any')
url="https://wiki.gnome.org/Projects/BuildStream/"
license=('LGPL')
depends=(bubblewrap ostree python-click python-jinja
- python-gobject python-grpcio python-pluginbase python-protobuf
- python-psutil python-ruamel-yaml
+ python-gobject python-grpcio python-pluginbase
+ python-protobuf python-psutil python-ruamel-yaml
# specific host site dependencies
bzr git lzip python-arpy)
makedepends=(python-setuptools)
source=("https://download.gnome.org/sources/BuildStream/${pkgver%.*}/BuildStream-$pkgver.tar.xz")
-sha256sums=('04333fe9e09f69f00d5e6da0aff109f9620e84d624be88082965847eabdb4305')
+sha256sums=('dd0b04e239c362e7ac44e202874da6e9ebfaaad038db513b9af3d57904f77e91')
build() {
cd BuildStream-$pkgver