summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2019-07-16 18:29:08 -0300
committerRafael Fontenelle2019-07-16 18:29:08 -0300
commita102b7c64aed38c40b7d76f61619e7ef294d0f21 (patch)
tree586758ab99432c7856817b10ad9d1e92781e6f81
parent58a8a094a7c66acdef786a55bb8da43bce21cbbc (diff)
downloadaur-a102b7c64aed38c40b7d76f61619e7ef294d0f21.tar.gz
Update to 1.3.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec64bd50ba77..f30dbd3c51f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = buildstream
pkgdesc = Framework for modelling build pipelines in a declarative YAML format
- pkgver = 1.2.7
+ pkgver = 1.3.1
pkgrel = 1
url = https://buildstream.build/
arch = any
license = LGPL
makedepends = python-setuptools
+ makedepends = cython
depends = bubblewrap
depends = ostree
depends = python-click
@@ -15,13 +16,15 @@ pkgbase = buildstream
depends = python-pluginbase
depends = python-protobuf
depends = python-psutil
+ depends = python-pyroaring
depends = python-ruamel-yaml0.15.51
+ depends = python-ujson
depends = bzr
depends = git
depends = lzip
depends = python-arpy
- source = https://download.gnome.org/sources/BuildStream/1.2/BuildStream-1.2.7.tar.xz
- sha256sums = c73b25edd21194e615ead358551d272bc37703832c6829fbe9d3849141bb6145
+ source = https://download.gnome.org/sources/BuildStream/1.3/BuildStream-1.3.1.tar.xz
+ sha256sums = ccc43733cc099ef743964ff2cedf0c262e2e1c30d0f6c8ee021a94249d581ae7
pkgname = buildstream
diff --git a/PKGBUILD b/PKGBUILD
index a3f4b5a51ee5..70ca73179049 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=buildstream
-pkgver=1.2.7
+pkgver=1.3.1
pkgrel=1
pkgdesc="Framework for modelling build pipelines in a declarative YAML format"
arch=('any')
@@ -8,13 +8,13 @@ url="https://buildstream.build/"
license=('LGPL')
depends=(bubblewrap ostree python-click python-jinja
python-gobject python-grpcio python-pluginbase
- python-protobuf python-psutil
- python-ruamel-yaml0.15.51
+ python-protobuf python-psutil python-pyroaring
+ python-ruamel-yaml0.15.51 python-ujson
# specific host site dependencies
bzr git lzip python-arpy)
-makedepends=(python-setuptools)
+makedepends=(python-setuptools cython)
source=("https://download.gnome.org/sources/BuildStream/${pkgver%.*}/BuildStream-$pkgver.tar.xz")
-sha256sums=('c73b25edd21194e615ead358551d272bc37703832c6829fbe9d3849141bb6145')
+sha256sums=('ccc43733cc099ef743964ff2cedf0c262e2e1c30d0f6c8ee021a94249d581ae7')
build() {
cd BuildStream-$pkgver