summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Semet2022-12-29 22:41:30 +0100
committerMarko Semet2022-12-29 22:42:25 +0100
commit780f2a4722f7b01578efd3e967aa99bb112c1630 (patch)
tree7f9bdc4f13506e892d10f00c38f84124f78d651a
downloadaur-780f2a4722f7b01578efd3e967aa99bb112c1630.tar.gz
Publish buildstream plugins
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD32
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f5c84e48edf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = buildstream-plugins
+ pkgdesc = A collection of plugins for the BuildStream project.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://buildstream.build
+ arch = any
+ license = Apache
+ makedepends = cython
+ makedepends = python-packaging
+ makedepends = python-setuptools
+ depends = buildstream
+ depends = bzr
+ depends = git
+ depends = patch
+ depends = python-pip
+ depends = python-requests
+ depends = python-tomli
+ source = git+https://github.com/apache/buildstream-plugins.git#tag=2.0.0&commit=da8218fa0a1d6c5870c7d11766b17fcd7fdd39c9
+ sha256sums = SKIP
+
+pkgname = buildstream-plugins
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aace9926737
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3affe1e6f2b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Marko Semet <marko10_000@mailbox.org>
+pkgname=buildstream-plugins
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A collection of plugins for the BuildStream project."
+arch=(any)
+url="https://buildstream.build"
+license=('Apache')
+depends=(
+ buildstream
+ # Programmes that are requered for the source plugins
+ bzr
+ git
+ patch
+ python-pip
+ python-requests
+ python-tomli # Replacement for “tomllib”
+ # Sources “cargo” and “docker” seam to not nead any programmes
+)
+makedepends=(cython python-packaging python-setuptools)
+source=("git+https://github.com/apache/buildstream-plugins.git#tag=2.0.0&commit=da8218fa0a1d6c5870c7d11766b17fcd7fdd39c9")
+sha256sums=('SKIP')
+
+build() {
+ cd buildstream-plugins
+ python setup.py build
+}
+
+package() {
+ cd buildstream-plugins
+ python setup.py install --root="$pkgdir/" --skip-build
+}