aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2017-09-10 19:04:59 -1000
committerGaetan Bisson2017-09-10 19:04:59 -1000
commit2dfdaa61d819237661f8febd1a3d6c0b67e5977c (patch)
treebca582089bc808a70e8dac24315c6c6ec1bbc6d8
parent6e15ef3235439099795b7ff78edf6f417d3dbe43 (diff)
downloadaur-2dfdaa61d819237661f8febd1a3d6c0b67e5977c.tar.gz
spawn multi-threaded vm's
-rw-r--r--PKGBUILD6
-rwxr-xr-xarch.build2
-rwxr-xr-xproxy.cgi4
3 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ef92275d6ca..a784a81e7405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=buildstuff
pkgver=0.9
-pkgrel=4
+pkgrel=5
pkgdesc='Stuff to build packages in virtual machines'
url='http://arch.vesath.org/'
arch=('any')
@@ -27,6 +27,6 @@ package() {
sha256sums=('386c1300cf5ce851a7532d8ee903c077193f61e2c01007c7991283b887228faf'
'acf683446e1162104759b1a75d18859b1a36ac6f3eeabb241025d0e6c37c7960'
- '8e55607c0948d8219fa7063f9df4fbb2c432275694253848a5fc1240275d7e36'
- '85da3d942596be0b69c5595b4edf8f6b46cd9185f55597db8cf370f5c401e410'
+ '8db3fcc4ac6d7d4238b921c4a28b1802426868be58111006340d101718c15a98'
+ '72307901efa866bdedf86c00dde6578cf5ce16ec801880f562d5fa57a82ad0d6'
'59e100c1140a109c8a98feb6ac5dc86e3830d2964ead74e820651b504b5829d4')
diff --git a/arch.build b/arch.build
index 03f654329ba3..d1cc9c9ca0a6 100755
--- a/arch.build
+++ b/arch.build
@@ -23,8 +23,8 @@ vhost="
start_vm() {
qemu-system-x86_64 \
- -machine accel=kvm:tcg \
-cpu $cpu -smp 4 -m 4G \
+ -accel kvm:tcg,thread=multi \
-device virtio-net,netdev=vlan \
-netdev user,id=vlan,hostfwd=::$vport-:22 \
-drive file=$1 &
diff --git a/proxy.cgi b/proxy.cgi
index 64d3b8e4a5bc..6847224f51ba 100755
--- a/proxy.cgi
+++ b/proxy.cgi
@@ -6,7 +6,7 @@ set -e
# requests to an actual mirror while caching contents to /var/cache/pacman/pkg.
# Use in pacman.conf with:
#
-# Server = https://server/path/to/proxy.cgi/$repo/os/$arch/
+# Server = http://server/path/to/proxy.cgi/$repo/os/$arch/
[[ $REMOTE_ADDR = 127.0.0.1 ]]
@@ -20,7 +20,7 @@ MIR=${MIR%/}
PKG=${PATH_INFO##*/}
if [[ $PATH_INFO = /vesath/* ]]; then
- MIR='https://arch.vesath.org/'
+ MIR='http://arch.vesath.org/'
PATH_INFO=${PATH_INFO#/vesath/os/}
fi