summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohnathan Jenkins2017-08-12 22:08:25 -0700
committerJohnathan Jenkins2017-08-12 22:08:25 -0700
commit26c1dbbdb37784aa95c1af5bdc92d6118102f295 (patch)
tree5dd2f837aec848595ffcd2e2d3f7fecdc64372e4
parent08e774f43800cb1d452a3be7ca7aae3495ff7d0a (diff)
downloadaur-26c1dbbdb37784aa95c1af5bdc92d6118102f295.tar.gz
include shell completion scripts
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2c7ce50e74b..c8d9d38129bf 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Aug 3 04:26:30 UTC 2017
+# Sun Aug 13 05:08:08 UTC 2017
pkgbase = buku
pkgdesc = cmdline bookmark management utility written in Python3 and SQLite3
pkgver = 3.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jarun/Buku
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 1f27f51e9c25..ca218ef8f0a5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=buku
pkgver=3.2
-pkgrel=1
+pkgrel=2
pkgdesc="cmdline bookmark management utility written in Python3 and SQLite3"
arch=('any')
depends=('python' 'python-beautifulsoup4' 'python-cryptography' 'python-requests' 'python-urllib3')
@@ -16,4 +16,7 @@ package() {
cd "$srcdir/Buku-$pkgver"
install -Dm 644 $pkgname.1 "${pkgdir}/usr/share/man/man1/$pkgname.1"
python setup.py install --root=${pkgdir} --prefix=/usr
+ install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish"
+ install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/etc/bash_completion.d/buku"
+ install -Dm644 auto-completion/zsh/_buku "${pkgdir}/usr/share/zsh/site-functions/_buku"
}