summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Steinke2016-06-04 09:45:22 +0200
committerRasmus Steinke2016-06-04 09:45:22 +0200
commite039e067604fe92445f86b590acff8d9f3c58750 (patch)
tree8235c5e90de8d68eaf0740582a5a9561c81bfcbe
downloadaur-e039e067604fe92445f86b590acff8d9f3c58750.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa7a10f01838
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jun 4 07:45:08 UTC 2016
+pkgbase = buku-git
+ pkgdesc = cmdline bookmark management utility written in Python3 and SQLite3
+ pkgver = 556.0fec5de
+ pkgrel = 1
+ url = https://github.com/jarun/Buku
+ arch = any
+ license = GPL3
+ makedepends = make
+ depends = python
+ depends = python-crypto
+ depends = sqlite
+ source = git+https://github.com/jarun/buku.git
+ md5sums = SKIP
+
+pkgname = buku-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b03903fdb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Rasmus Steinke <rasi at xssn dot at>
+
+pkgname=buku-git
+_pkgname=buku
+pkgver=556.0fec5de
+pkgrel=1
+pkgdesc="cmdline bookmark management utility written in Python3 and SQLite3"
+arch=('any')
+depends=('python' 'python-crypto' 'sqlite')
+makedepends=('make')
+url="https://github.com/jarun/Buku"
+license=('GPL3')
+source=('git+https://github.com/jarun/buku.git')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}
+
+md5sums=('SKIP')