summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel2020-10-30 17:01:42 -0300
committerDaniel2020-10-30 17:01:42 -0300
commit473bf5a51372bbb177ce49573bbe1e6a269f7514 (patch)
tree4f9f00bf5376328a951a36b5bbfa7c81c25d0657
downloadaur-buku-rofi-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9586c1235f0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = buku-rofi-git
+ pkgdesc = rofi frontend for buku bookmarks manager
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/lbcnz/agnostic-browser
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gawk
+ depends = buku
+ depends = rofi
+ provides = buku-rofi
+ source = git+https://gitlab.com/lbcnz/buku-rofi.git
+ md5sums = SKIP
+
+pkgname = buku-rofi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d16cd7fd7abc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: daniel de souza telles <danieldesouzatelles at gmail dot com>
+pkgname=buku-rofi-git
+_pkgname=buku-rofi
+pkgver=1.0
+pkgrel=1
+pkgdesc="rofi frontend for buku bookmarks manager"
+arch=('any')
+url='https://gitlab.com/lbcnz/agnostic-browser'
+provides=('buku-rofi')
+license=('GPL')
+depends=('gawk' 'buku' 'rofi')
+makedepends=('git')
+source=("git+https://gitlab.com/lbcnz/${_pkgname}.git")
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="$pkgdir/" \
+ PREFIX='/usr' \
+ install
+}
+
+md5sums=('SKIP')
+