summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Oliver2020-01-31 16:46:39 +0000
committerBen Oliver2020-01-31 16:46:39 +0000
commit6b38f04cc3c3e4d9d7997f1a3be1994f915f1536 (patch)
treeed38610193af9ff7574997ff1cd590aff172c66c
parent8df1bd53a45b00b2ca9109a60da9c34a1e968e2c (diff)
downloadaur-6b38f04cc3c3e4d9d7997f1a3be1994f915f1536.tar.gz
v4.3 update
-rw-r--r--.SRCINFO9
-rwxr-xr-xPKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 061ddaa91c1d..6d141daef32c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = bukuserver
pkgdesc = Powerful command-line bookmark manager. CLI and server.
- pkgver = 4.2.2
- pkgrel = 2
+ pkgver = 4.3
+ pkgrel = 1
url = https://github.com/jarun/Buku
arch = any
license = GPL3
makedepends = make
depends = python
+ depends = python-flask-reverse-proxy-fix
depends = python-beautifulsoup4
depends = python-cryptography
depends = python-urllib3
@@ -33,8 +34,8 @@ pkgbase = bukuserver
depends = python-werkzeug
provides = buku
conflicts = buku
- source = bukuserver-4.2.2.tar.gz::https://codeload.github.com/jarun/Buku/tar.gz/v4.2.2
- sha256sums = 08866f284a03454d9ee5bbb332da62e6ae1dfbe83ada75092453a7fd04fe62b3
+ source = bukuserver-4.3.tar.gz::https://codeload.github.com/jarun/Buku/tar.gz/v4.3
+ sha256sums = 4c91cb0ac83164153c65705f46af29aaede78a2ed48d836cd2269b0fc71fed7a
pkgname = bukuserver
diff --git a/PKGBUILD b/PKGBUILD
index a34d26efeb80..34a4d842746b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Ben Oliver <ben@bfoliver.com>
pkgname=bukuserver
-pkgver=4.2.2
-pkgrel=2
+pkgver=4.3
+pkgrel=1
pkgdesc="Powerful command-line bookmark manager. CLI and server."
arch=('any')
-depends=('python' 'python-beautifulsoup4' 'python-cryptography' 'python-urllib3' 'python-certifi' 'python-html5lib' 'python-appdirs' 'python-arrow' 'python-cffi' 'python-click' 'python-flask-admin' 'python-flask-api' 'python-flask-bootstrap' 'python-flask-paginate' 'python-flask-wtf' 'python-idna' 'python-itsdangerous' 'python-jinja' 'python-markupsafe' 'python-packaging' 'python-pyasn1' 'python-pycparser' 'python-requests' 'python-six' 'python-werkzeug')
+depends=('python' 'python-flask-reverse-proxy-fix' 'python-beautifulsoup4' 'python-cryptography' 'python-urllib3' 'python-certifi' 'python-html5lib' 'python-appdirs' 'python-arrow' 'python-cffi' 'python-click' 'python-flask-admin' 'python-flask-api' 'python-flask-bootstrap' 'python-flask-paginate' 'python-flask-wtf' 'python-idna' 'python-itsdangerous' 'python-jinja' 'python-markupsafe' 'python-packaging' 'python-pyasn1' 'python-pycparser' 'python-requests' 'python-six' 'python-werkzeug')
makedepends=('make')
conflicts=('buku')
provides=('buku')
url="https://github.com/jarun/Buku"
license=('GPL3')
source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jarun/Buku/tar.gz/v$pkgver)
-sha256sums=('08866f284a03454d9ee5bbb332da62e6ae1dfbe83ada75092453a7fd04fe62b3')
+sha256sums=('4c91cb0ac83164153c65705f46af29aaede78a2ed48d836cd2269b0fc71fed7a')
package() {
- cd "$srcdir/Buku-$pkgver"
+ cd "$srcdir/buku-$pkgver"
python setup.py install --root="${pkgdir}" --prefix=/usr
install -Dm644 auto-completion/fish/buku.fish "${pkgdir}/usr/share/fish/vendor_completions.d/buku.fish"
install -Dm644 auto-completion/bash/buku-completion.bash "${pkgdir}/etc/bash_completion.d/buku"