summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2015-07-19 16:09:44 +0200
committermar77i2015-07-19 16:09:44 +0200
commit43b69dcddecd592ac8f3692788bfd5e2613c3db2 (patch)
tree0bc2af844392eb25f189f1b5d4fc3a7d02d4b652
downloadaur-43b69dcddecd592ac8f3692788bfd5e2613c3db2.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0e36780c822
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bulk77i-apps-git
+ pkgdesc = mar77i's basic C datatypes collection
+ pkgver = v0.2.4.g4b04119
+ pkgrel = 1
+ url = https://github.com/mar77i/bulk77i-apps
+ arch = x686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/mar77i/bulk77i-apps.git
+ md5sums = SKIP
+
+pkgname = bulk77i-apps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e21fc1cee489
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: mar77i <mar77i at mar77i dot ch>
+pkgname=bulk77i-apps-git
+_pkgname=bulk77i-apps
+pkgrel=1
+pkgver=v0.2.4.g4b04119
+pkgdesc="mar77i's basic C datatypes collection"
+arch=(x686 x86_64)
+url="https://github.com/mar77i/bulk77i-apps"
+license=('GPL')
+makedepends=('git' 'bulk77i-git')
+source=("git+https://github.com/mar77i/bulk77i-apps.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags |sed 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ local lpfx="/usr/share/licenses"
+ cd "$srcdir"
+ make -C "$_pkgname" DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -m644 -D "$_pkgname/LICENSE" "$pkgdir/$lpfx/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: